Bug 123532 - Rhythmbox infloops importing .wma files
Rhythmbox infloops importing .wma files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 01:11 EDT by Brian Smith
Modified: 2013-03-13 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-15 11:52:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Smith 2004-05-19 01:11:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When I try to add a folder to the Rhythmbox library (note, the library
is empty) that fairly large, rhythmbox never adds it.  It hangs on the
search.  When you try to quit, you can't and have to send a SIGKILL to
it to stop it.

Version-Release number of selected component (if applicable):
rhythmbox-0.8.3-3

How reproducible:
Always

Steps to Reproduce:
1.From the default install, open Rhythmbox
2.Import a folder with multiple file types along with mp3 and ogg

    

Actual Results:  Rhythmbox hangs and will not finish adding the folder
to the library.

Expected Results:  Rhythmbox should load all ogg and mp3 files (after
you've installed the gstreamer-mp3 plugins) and add them to the library.

Additional info:
Comment 1 Colin Walters 2004-05-19 08:12:04 EDT
Do you have any windows media (.wma) files in there? 
Comment 2 Brian Smith 2004-05-19 17:37:47 EDT
Yes, there are a ton.  Is this a problem, because it shouldn't be. 
And, do you know if there is a gstreamer-plugin (unofficial or from
the gstreamer group) for wma files?  

Thanks
Comment 3 Colin Walters 2004-05-19 17:54:58 EDT
I fixed this problem in the gstreamer-plugins CVS.  I plan to push an
errata for gstreamer-plugins for FC2.

As for a wma decoder, I believe there is a plugin in the upstream CVS.
Comment 4 Brian Smith 2004-05-19 18:22:35 EDT
Alrighty then.  I'll wait for the errata.  Thanks for the heads up. 
Dag Weeirs will probably have an rpm for it that will encompass the
wma plugin pretty soon so I'll likely grab his rpms.

Thanks!
Comment 5 Colin Walters 2004-07-27 11:33:45 EDT
This should be fixed now in the latest gstreamer-plugins update. 
Brian, can you confirm?
Comment 6 John Thacker 2006-04-15 11:52:14 EDT
This is fixed, and with no update from the reporter in a year and a half after
the fix was applied, I'm closing the bug.

Note You need to log in before you can comment on or make changes to this bug.