Bug 1235334 - NeutronControlPlaneID is set to empty string in tuskar overcloud plan
Summary: NeutronControlPlaneID is set to empty string in tuskar overcloud plan
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Director
Assignee: Lennart Regebro
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-24 14:28 UTC by Jan Provaznik
Modified: 2015-08-05 13:55 UTC (History)
9 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-16.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:55:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 195592 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Jan Provaznik 2015-06-24 14:28:04 UTC
Description of problem:
After deploying an overcloud, NeutronControlPlaneID param is set to '' in tuskar plan. This causes that both "openstack overcloud update stack" and "openstack overcloud node delete" commands fail.

The reason why "openstack overcloud deploy" command works is that it sets NeutronControlPlaneID parameter before any stack create/update API call. This doesn't make much sense - I think one of following should be done:
a) don't set empty NeutronControlPlaneID param in tuskar at all
b) update NeutronControlPlaneID param in tuskar on overcloud create/update

Steps to Reproduce:
1. deploy overcloud following doc ("openstack overcloud deploy")
2. fetch tuskar plan templates: tuskar plan-templates -O tpls $PLAN_UUID
3. check NeutronControlPlaneID is set to '' in tpls/environment.yaml

This is a regression - in pre-unifiedCLI age there was not problem with this.

Comment 3 Marios Andreou 2015-06-25 10:23:40 UTC
Jan you are right and in fact it is the same for every other variable that is set for a deploy. The difference between [1] (old way) and [2] is that before we were actually patching the tuskar plan with the user-supplied params before requesting the deploy templates. Now, the templates are requested, the user params are also passed like [3] so you get what you want but it isn't persisted in Tuskar.

We came across this in scrum on the 17th and it was my impression that someone was already working on changing that behaviour in the osc plugin. I think possibly dmathews or regebro?




[1] https://github.com/rdo-management/instack-undercloud/blob/master/scripts/instack-deploy-overcloud#L289

[2] https://github.com/rdo-management/python-rdomanager-oscplugin/blob/master/rdomanager_oscplugin/v1/overcloud_deploy.py#L395

[3] https://github.com/rdo-management/python-rdomanager-oscplugin/blob/master/rdomanager_oscplugin/v1/overcloud_deploy.py#L340

Comment 5 Lennart Regebro 2015-07-01 12:17:27 UTC
I believe this bug is fixed by this patch:

https://review.gerrithub.io/#/c/237713/

Comment 6 Mike Burns 2015-07-01 15:55:24 UTC
(In reply to Lennart Regebro from comment #5)
> I believe this bug is fixed by this patch:
> 
> https://review.gerrithub.io/#/c/237713/

This is in place of the previous patch

Comment 8 Ofer Blaut 2015-07-08 14:34:12 UTC
stack@puma33 ~]$ openstack management plan list
+--------------------------------------+-----------+-------------+------------------------------------------------------------------+
| uuid                                 | name      | description | roles                                                            |
+--------------------------------------+-----------+-------------+------------------------------------------------------------------+
| 27f1ac33-6c9d-4d02-a3c9-e0ca463f3b11 | overcloud | None        | Compute, Ceph-Storage, Cinder-Storage, Controller, Swift-Storage |
+--------------------------------------+-----------+-------------+------------------------------------------------------------------+
[stack@puma33 ~]$ grep NeutronControlPlaneID  tpls/environment.yaml 
  NeutronControlPlaneID: 548752ae-51fd-491c-b281-b48a6cbb6d9a

python-rdomanager-oscplugin-0.0.8-18.el7ost.noarch

Comment 10 errata-xmlrpc 2015-08-05 13:55:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.