Bug 1235378 - PUT /api/v2/hostgroups/:id returns an incomplete set of attributes
Summary: PUT /api/v2/hostgroups/:id returns an incomplete set of attributes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: API
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: alon
QA Contact: jcallaha
URL:
Whiteboard:
Depends On: 1216236
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-24 16:18 UTC by jaudet
Modified: 2019-09-25 21:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:53:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
Output of foreman-debug from a Satellite 6.1.0 system running RHEL 6.6. (1.60 MB, application/x-xz)
2015-06-24 16:18 UTC, jaudet
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description jaudet 2015-06-24 16:18:58 UTC
Created attachment 1042786 [details]
Output of foreman-debug from a Satellite 6.1.0 system running RHEL 6.6.

Description of problem:
A hostgroup has at least the following attributes:

* architecture
* content_view
* domain
* environment
* id
* lifecycle_environment
* location
* medium
* name
* operatingsystem
* organization
* parent
* ptable
* realm
* subnet

PUT /api/v2/hostgroups/:id returns the following attributes:

* ancestry
* architecture_id
* compute_profile_id
* content_source_id
* content_view_id
* created_at
* domain_id
* environment_id
* grub_pass
* id
* image_file
* lifecycle_environment_id
* medium_id
* name
* operatingsystem_id
* ptable_id
* puppet_ca_proxy_id
* puppet_proxy_id
* realm_id
* root_pass
* subnet_id
* title
* updated_at
* use_image
* vm_defaults

The following attributes are not mentioned in the response:

* location
* organization

Version-Release number of selected component (if applicable):
Satellite 6.1.0. Foreman-debug is attached.

How reproductible:
100%

Steps to Reproduce:
1. Issue an HTTP PUT request to `/api/v2/hostgroups/:id`.
2. Capture the response and examine the JSON contents.
3. Discover that several attributes are missing.

Actual results:
See above.

Expected results:
See above.

Additional info:

Comment 1 RHEL Program Management 2015-06-24 16:22:40 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 alon 2015-07-14 12:21:08 UTC
Fixed in http://projects.theforeman.org/issues/10356

Comment 4 Tomer Brisker 2016-04-12 12:50:00 UTC
This has been resolved in current 6.2 snaps, moving to ON_QA for verification.

Comment 5 jcallaha 2016-05-25 17:37:09 UTC
Verified in Satellite 6.2 Beta Snap 12.

{
  "subnet_id": null,
  "subnet_name": null,
  "operatingsystem_id": null,
  "operatingsystem_name": null,
  "domain_id": null,
  "domain_name": null,
  "environment_id": null,
  "environment_name": null,
  "compute_profile_id": null,
  "compute_profile_name": null,
  "ancestry": null,
  "parent_id": null,
  "parent_name": null,
  "puppet_proxy_id": 1,
  "puppet_ca_proxy_id": 1,
  "ptable_id": null,
  "ptable_name": null,
  "medium_id": null,
  "medium_name": null,
  "architecture_id": null,
  "architecture_name": null,
  "realm_id": null,
  "realm_name": null,
  "created_at": "2016-05-25 17:30:41 UTC",
  "updated_at": "2016-05-25 17:31:35 UTC",
  "id": 1,
  "name": "chief_client",
  "title": "chief_client",
  "parameters": [
    {
      "id": 1,
      "name": "kt_activation_keys",
      "value": "rhel7 beta"
    }
  ],
  "template_combinations": [],
  "puppetclasses": [],
  "config_groups": [],
  "all_puppetclasses": [],
  "locations": [
    {
      "id": 2,
      "name": "Default Location",
      "title": "Default Location",
      "description": null
    }
  ],
  "organizations": [
    {
      "id": 1,
      "name": "Default Organization",
      "title": "Default Organization",
      "description": null
    }
  ]
}

Comment 7 errata-xmlrpc 2016-07-27 08:53:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.