Bug 1235538 - Porting the left out gf_log messages to the new logging API
Summary: Porting the left out gf_log messages to the new logging API
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Nandaja Varma
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-25 06:40 UTC by Nandaja Varma
Modified: 2016-06-16 13:16 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 13:16:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nandaja Varma 2015-06-25 06:40:31 UTC
Description of problem:

The current implementation of logging is missing in some files in glusterd.
The logging have to be implemented for all files under glusterd for better reading of log file and consistency.

Version-Release number of selected component (if applicable):

N/A

How reproducible:

N/A

Steps to Reproduce:
N/A

Actual results:

Unavailability of new logging mechanism (MSG ID) in some glusterd files.

Expected results:

Implement logging based on message ids in some glusterd files.

Comment 1 Anand Avati 2015-06-25 06:41:45 UTC
REVIEW: http://review.gluster.org/11388 (glusterd: Porting left out log messages to new framework) posted (#2) for review on master by Nandaja Varma (nandaja.varma@gmail.com)

Comment 2 Anand Avati 2015-06-25 10:49:48 UTC
REVIEW: http://review.gluster.org/11388 (glusterd: Porting left out log messages to new framework) posted (#4) for review on master by Nandaja Varma (nandaja.varma@gmail.com)

Comment 3 Anand Avati 2015-06-26 04:46:54 UTC
REVIEW: http://review.gluster.org/11388 (glusterd: Porting left out log messages to new framework) posted (#5) for review on master by Nandaja Varma (nandaja.varma@gmail.com)

Comment 4 Anand Avati 2015-06-26 10:39:45 UTC
REVIEW: http://review.gluster.org/11388 (glusterd: Porting left out log messages to new framework) posted (#8) for review on master by Nandaja Varma (nandaja.varma@gmail.com)

Comment 5 Anand Avati 2015-06-26 15:14:57 UTC
REVIEW: http://review.gluster.org/11388 (glusterd: Porting left out log messages to new framework) posted (#9) for review on master by Nandaja Varma (nandaja.varma@gmail.com)

Comment 6 Anand Avati 2015-07-09 06:47:23 UTC
REVIEW: http://review.gluster.org/11590 (glusterd: Porting the left out gf_log_callingfns to new framework) posted (#1) for review on master by Nandaja Varma (nandaja.varma@gmail.com)

Comment 7 Anand Avati 2015-07-09 09:25:29 UTC
REVIEW: http://review.gluster.org/11590 (glusterd: Porting the left out gf_log_callingfns to new framework) posted (#2) for review on master by Nandaja Varma (nandaja.varma@gmail.com)

Comment 8 Anand Avati 2015-07-15 05:03:52 UTC
REVIEW: http://review.gluster.org/11590 (glusterd: Porting the left out gf_log_callingfns to new framework) posted (#3) for review on master by Nandaja Varma (nandaja.varma@gmail.com)

Comment 9 Anand Avati 2015-07-16 09:27:02 UTC
REVIEW: http://review.gluster.org/11590 (glusterd: Porting the left out gf_log_callingfns to new framework) posted (#5) for review on master by Nandaja Varma (nandaja.varma@gmail.com)

Comment 10 Anand Avati 2015-07-17 04:52:22 UTC
REVIEW: http://review.gluster.org/11590 (glusterd: Porting the left out gf_log_callingfns to new framework) posted (#6) for review on master by Nandaja Varma (nandaja.varma@gmail.com)

Comment 11 Anand Avati 2015-07-18 12:08:07 UTC
COMMIT: http://review.gluster.org/11590 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit b2673ae923f3e4651f4c642a9b88f5d200a25585
Author: Nandaja Varma <nandaja.varma@gmail.com>
Date:   Thu Jul 9 11:37:16 2015 +0530

    glusterd: Porting the left out gf_log_callingfns to new framework
    
    Change-Id: I1b0ad54238895475ddbacc4fffacac8dc6e887fe
    BUG: 1235538
    Signed-off-by: Nandaja Varma <nandaja.varma@gmail.com>
    Reviewed-on: http://review.gluster.org/11590
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 12 Kaleb KEITHLEY 2015-10-22 17:00:12 UTC
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.

Comment 13 Kaleb KEITHLEY 2015-10-22 17:06:51 UTC
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.

Comment 14 Kaleb KEITHLEY 2015-10-22 17:11:18 UTC
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.

Comment 15 Niels de Vos 2016-06-16 13:16:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.