Bug 1235560 - [New] - starting volume from UI displays incorrect event log message.
Summary: [New] - starting volume from UI displays incorrect event log message.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: rhgs-3.1
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
: RHGS 3.1.1
Assignee: anmol babu
QA Contact: RamaKasturi
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks: 1251815
TreeView+ depends on / blocked
 
Reported: 2015-06-25 07:48 UTC by RamaKasturi
Modified: 2015-10-05 09:21 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-10-05 09:21:41 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1848 normal SHIPPED_LIVE Red Hat Gluster Storage Console 3.1 update 1 bug fixes 2015-10-05 13:19:50 UTC
oVirt gerrit 43850 master MERGED engine : Fix brick state change messages on start volume Never
oVirt gerrit 44225 ovirt-engine-3.5-gluster MERGED engine : Fix brick state change messages on start volume Never

Description RamaKasturi 2015-06-25 07:48:52 UTC
Description of problem:
When user creates a new volume from UI and starts it there are event log messages which says "Detected change in status of brick from DOWN to UP". 

The above said event message is displayed in UI only when the brick is brought down and brought up back again. This was not the behaviour in the previous releases.

Version-Release number of selected component (if applicable):
rhsc-3.1.0-0.61.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a volume from UI
2. Now start the volume.
3.

Actual results:
Event log message says "Detected change in status of the brick from DOWN to UP" when a volume is started.

Expected results:
Above message should not be displayed in the event logs when user starts a volume.

Additional info:

Comment 2 Sahina Bose 2015-06-25 15:13:03 UTC
This change was introduced due to https://gerrit.ovirt.org/#/c/40232/ - where we needed the volume details to be synced for geo-rep to work after volume creation.

Comment 4 Sahina Bose 2015-06-30 10:35:08 UTC
Deferring this as it has no functionality impact

Comment 13 RamaKasturi 2015-08-18 07:28:11 UTC
Verified and works fine with build rhsc-setup-3.1.1-0.63.el6.noarch.

with this fix when user creates a volume and starts it from UI, Event log does not display messages like  "Detected change in status of the brick from DOWN to UP".

Comment 15 errata-xmlrpc 2015-10-05 09:21:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1848.html


Note You need to log in before you can comment on or make changes to this bug.