Bug 123564 - An unhandled exception occured after installation of RPMs
Summary: An unhandled exception occured after installation of RPMs
Status: CLOSED DUPLICATE of bug 119447
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 2
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-19 12:43 UTC by Rainer Koenig
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rainer Koenig 2004-05-19 12:43:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20040130 Firebird/0.7

Description of problem:
When installing Fedora Core 2 for x86_64 the installation hangs after
inserting CD3 and klicking on OK.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from Fedora Core 2 (x86_64) CD1 
2. Follow installation instructions until CD3 is required
3. Insert CD3 and klick OK
    

Actual Results:  System hangs showing an hourglass. Mouse is not
responding any more, a Window with an error message pops up (see
additional information below).

Expected Results:  Installation going on.

Additional info:

Looks like the error occurs after installing all the RPM packets and
starting the configuration. A popup window appears which tells me that
an unhandled exception occured and that I should file that as a bug in
anaconda. The text in the window is:

Traceback (most recent call last):
File "/usr/lib/ananconda/gui.py", line 1048, in handleRednerCallback
self.currentWindow.renderCallback()
File "/usr/lib/anaconda/progress_gui.py", line 242 in RnderCallback
self.intf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py", line 763, in nextClicked
self.dispatch.goNext()
File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
self.moveStep()
File "/usr/lib/anaconda/packages.py", line 1125, in do PostInstall
devnull=os.open("/dev/null", os.O_RDWR)
OS.Error: [Errno5] Input-/Output-Error: '/dev/null'

Comment 1 Jeremy Katz 2004-05-20 02:16:57 UTC
Did you verify your media with the mediacheck according to the
instructions at http://rhlinux.redhat.com/anaconda/mediacheck.html?

Comment 2 Rainer Koenig 2004-05-20 18:56:43 UTC
Yes, I checked all 4 disks with the mediacheck that is performed after
booting from CD1. All 4 CDs passed without any problems. 

Comment 3 Pete Stieber 2004-07-08 14:19:03 UTC
I am having roughly the same problem after the fourth CD in an x86_64 
install. I believe the reason for for the extra CD is I am installing 
every package, so all of the CDs must be used. I am using a Tyan 
Tomcat K8S(S2850G2N) motherboard. The mouse becomes unusabe, but is 
not an hour glass but simple an I-bar text edit cursor. I can still 
use the keyboard to navigate.

I did verify the CDs, and they have used to install the OS on other 
machines with a different (Tyan Thunder K8W(S2885ANRF)) motherboard.

I belive my dump is the same as that described above except I belive 
there are a few typos and a missing line in the first post. This is 
understandable since the information must be recorded by hand. The 
version I recorded follows.

Traceback (most recent call last):
File "/usr/lib/ananconda/gui.py", line 1048, in handleRednerCallback
self.currentWindow.renderCallback()
File "/usr/lib/anaconda/progress_gui.py", line 242 in renderCallback
self.inf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py", line 763, in nextClicked
self.dispatch.goNext()
File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep
rc=apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 1125, in doPostInstall
devnull=os.open("/dev/null", os.O_RDWR)
OS.Error: [Errno5] Input/Output error: '/dev/null'

If I hit the Debug button in the resulting dialog I get

packages.py (1212) doPostInstall()
-> pass
(pdb)

I didn't know what to try next.

After rebooting grub comes up and I can use

kernel /vmlinux-2.2... (can't remember the name but hasn't been moved 
to the boot directory due to the install crash)
boot

to get the machine to boot, but it's a mess since the normal install 
died.

I'm very willing to recreate the crime and provide additional 
information or try various install options.

Comment 4 Pete Stieber 2004-07-09 17:54:21 UTC
See bug number 124029. The work around for me was to use

linux mem=256M

when installing. My HW

MB: Tyan Tomcat K8S(S2850G2N)
Processor: AMD Opteron 146 (2GHz)
RAM: 1 GB
HD: Maxtor 80GB 7200 RPM IDE ULTRA ATA 133

Maybe it's a problem with x86_64 systems with more that X MB of 
memory where X > 256M.

Comment 5 Jeremy Katz 2004-10-07 18:17:41 UTC

*** This bug has been marked as a duplicate of 119447 ***

Comment 6 Red Hat Bugzilla 2006-02-21 19:03:18 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.