Bug 123565 - s-c-mouse doesn't seem to ever change the X config
Summary: s-c-mouse doesn't seem to ever change the X config
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-mouse (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-19 12:46 UTC by Miloslav Trmac
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 16:22:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Miloslav Trmac 2004-05-19 12:46:47 UTC
Description of problem:
Looking at the current mouse_backend.py, it AFAICS never changes
the X config, for two reasons:
* From revision 1.12 on, the first statement of modifyXconfig
  is "return"
* The rest of the function is skipped if /etc/X11/XF86Config
  does not exist, which is the case with X.org X11.
  Note that there are other references to this file in
  mouse_[gt]uil.py

Version-Release number of selected component (if applicable):
system-config-mouse-1.2.6-2

Comment 1 Brent Fox 2004-06-24 16:22:34 UTC
This shouldn't be a problem with the 2.6 kernel.  It's not necessary
to change xorg.conf or XF86Config since all mice now use
"/dev/input/mice" on the "Device" line.  In fact, the entire
"modifyXconfig" function should probably be removed from mouse_backend.py.


Note You need to log in before you can comment on or make changes to this bug.