Bug 1235652 - Overcloud:HA: Fence agents packages are not installed on controllers after overcloud deployment. Fencing can not be used.
Summary: Overcloud:HA: Fence agents packages are not installed on controllers after ov...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-puppet-elements
Version: Director
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ga
: Director
Assignee: James Slagle
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-25 12:43 UTC by Leonid Natapov
Modified: 2015-08-05 13:56 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-puppet-elements-0.0.1-3.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:56:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 185597 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Leonid Natapov 2015-06-25 12:43:52 UTC
Description of problem:

Overcloud:HA: Fence agents packages are not installed on controllers after overcloud deployment. Fencing can not be defined.

[heat-admin@overcloud-controller-0 ~]$ rpm -qa | grep fence
[heat-admin@overcloud-controller-0 ~]$ 


For example staypuft deployment:

[root@macb8ca3a60bde8 ~]# rpm -qa | grep fence
fence-agents-kdump-4.0.11-11.el7_1.x86_64
fence-agents-ifmib-4.0.11-11.el7_1.x86_64
fence-agents-rhevm-4.0.11-11.el7_1.x86_64
fence-agents-hpblade-4.0.11-11.el7_1.x86_64
fence-agents-wti-4.0.11-11.el7_1.x86_64
fence-agents-scsi-4.0.11-11.el7_1.x86_64
fence-agents-common-4.0.11-11.el7_1.x86_64
fence-agents-ilo2-4.0.11-11.el7_1.x86_64
fence-agents-apc-snmp-4.0.11-11.el7_1.x86_64
fence-agents-intelmodular-4.0.11-11.el7_1.x86_64
fence-agents-vmware-soap-4.0.11-11.el7_1.x86_64
fence-agents-bladecenter-4.0.11-11.el7_1.x86_64
fence-agents-ilo-ssh-4.0.11-11.el7_1.x86_64
fence-agents-cisco-mds-4.0.11-11.el7_1.x86_64
fence-agents-ibmblade-4.0.11-11.el7_1.x86_64
fence-agents-cisco-ucs-4.0.11-11.el7_1.x86_64
fence-agents-rsb-4.0.11-11.el7_1.x86_64
fence-agents-eps-4.0.11-11.el7_1.x86_64
fence-agents-ilo-mp-4.0.11-11.el7_1.x86_64
fence-agents-all-4.0.11-11.el7_1.x86_64
fence-agents-ipdu-4.0.11-11.el7_1.x86_64
fence-agents-brocade-4.0.11-11.el7_1.x86_64
fence-agents-apc-4.0.11-11.el7_1.x86_64
fence-agents-drac5-4.0.11-11.el7_1.x86_64
fence-agents-eaton-snmp-4.0.11-11.el7_1.x86_64
fence-agents-ipmilan-4.0.11-11.el7_1.x86_64
fence-virt-0.3.2-1.el7.x86_64

Comment 2 chris alfonso 2015-06-25 17:33:22 UTC
You can use yum install fence-agents-all as a workaround.

Comment 3 James Slagle 2015-06-26 18:11:44 UTC
this needs a qa_ack

Comment 5 Leonid Natapov 2015-07-06 05:06:29 UTC
fence packages are installed.
openstack-tripleo-puppet-elements-0.0.1-3.el7ost

Comment 7 errata-xmlrpc 2015-08-05 13:56:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.