Bug 1235667 - Overcloud create failed because of DracOperationFailed
Summary: Overcloud create failed because of DracOperationFailed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: Director
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ga
: Director
Assignee: Imre Farkas
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-25 13:12 UTC by Dariusz Smigiel
Modified: 2016-09-20 05:03 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, in cases when ironic-discoverd submitted a 'set_boot_device' request with the same boot device already configured on the node, the DRAC driver in OpenStack Bare Metal Provisioning (ironic) tried to commit a configuration job against BIOS without any change, resulting in a failed deployment. With this update, the DRAC driver in OpenStack Bare Metal Provisioning ignores requests where the target boot device is the same as the current one. As a result, the deployment succeeds.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:56:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
iDrac spec (7.00 KB, image/png)
2015-06-25 13:12 UTC, Dariusz Smigiel
no flags Details
console logs (13.29 KB, text/plain)
2015-06-25 13:12 UTC, Dariusz Smigiel
no flags Details
ironic (573.01 KB, text/plain)
2015-06-25 13:12 UTC, Dariusz Smigiel
no flags Details
nova conductor (20.41 KB, text/plain)
2015-06-25 13:13 UTC, Dariusz Smigiel
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Dariusz Smigiel 2015-06-25 13:12:05 UTC
Created attachment 1043100 [details]
iDrac spec

User is not able to finish deployment of Overcloud, because creation of stack fails.

Version-Release number of selected component (if applicable): OSP7 beta2, Director beta1


Steps to Reproduce:
0. HW: Dell iDrac (specification attached)
1. Install Undercloud
2. Run instack-deploy-overcloud --tuskar
3. Wait until it fails.

Possible problem: ironic cannot reprogram iDrac:
Jun 25 08:21:55 gklab-17-081 ironic-conductor: DracOperationFailed: ['No pending data present to create a Configuration job']

Logs attached.

Comment 3 Dariusz Smigiel 2015-06-25 13:12:31 UTC
Created attachment 1043101 [details]
console logs

Comment 4 Dariusz Smigiel 2015-06-25 13:12:49 UTC
Created attachment 1043102 [details]
ironic

Comment 5 Dariusz Smigiel 2015-06-25 13:13:09 UTC
Created attachment 1043103 [details]
nova conductor

Comment 7 Mike Burns 2015-06-29 11:54:31 UTC
This bug has been fixed in a subsequent build of ironic by bug 1231331

*** This bug has been marked as a duplicate of bug 1231331 ***

Comment 8 Mike Burns 2015-06-29 12:00:08 UTC
ok, not the same as that bug, but still fixed since the build included in the beta.  

Marking TestOnly

Comment 9 Dariusz Smigiel 2015-07-01 15:39:43 UTC
Installed RC2 and no longer experiencing this problem.

Comment 10 Alexander Chuzhoy 2015-07-20 13:43:17 UTC
Verified:

Environment: instack-undercloud-2.1.2-21.el7ost.noarch


Was able to deploy using the "openstack overcloud deploy" command.

Comment 12 errata-xmlrpc 2015-08-05 13:56:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.