Bug 123567 - (I2O) Installer unable to detect I2O (Adaptec 2010s) card
(I2O) Installer unable to detect I2O (Adaptec 2010s) card
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 09:00 EDT by Tom Sommer
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:57:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Sommer 2004-05-19 09:00:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
We have several machines using the Adaptec 2010s SCSI card.

We just tried to install Fedora Core 2 on one of these machines, and
it appears this driver for the 2.6 kernel is not included (as
described in the release notes). We've tried several things to get
this solved, including trying the workaround as described here:
http://www.redhat.com/archives/fedora-list/2004-May/msg03906.html
However none of this has worked and so I am filing this bug to work as
either a tracker or a simple bug for this issue.

We got this working on Fedora Core 1 with the 2.6 kernel, because Core
1 included the 2.4 kernel, and so we were able to install Fedora and
then afterwards install the 2.6 kernel with a patch located here:
http://cyrez.dk/i2o.patch

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
.

Additional info:
Comment 1 Warren Togami 2004-05-19 15:37:39 EDT
Which step on my procedure failed?  Were you able to make the module
load and verify that with lsmod?  This must be done BEFORE you go to
anaconda's Disk Druid step.
Comment 2 Warren Togami 2004-05-19 15:46:51 EDT
http://www.redhat.com/archives/fedora-list/2004-May/msg04389.html
At least one person reported success with my procedure with the i586
install.
Comment 3 Tom Sommer 2004-05-22 09:30:23 EDT
Yes, we loaded the module successfully before we went to disk druid,
however that did little to solve the problem once we got to the disk
druid, it simple said no disks were present.

At what point exactly do we have to load the module, is it specific,
or just before disk druid?

Our servers are using the Tyan i7501 Pro motherboard.

The question is if it enough to `insmod i2o_proc.ko` or it takes more
modules to work? We've tried inserting the Adaptec controller modules
also, but that has no effect ether.
Comment 4 Warren Togami 2004-05-26 18:12:57 EDT
http://marc.theaimsgroup.com/?l=linux-scsi&m=108548181512232&w=2
If that is an Adaptec "zero channel" card then you should try this
patch from Markus Lidel to see if the I2O block devices are
recognized.  We are unable to test it ourselves because we do not have
any "zero channel" models.
Comment 5 Tom Sommer 2004-05-26 18:25:03 EDT
It is an adaptec "Zero Channel" card. - So i'll test te patch. Could
you tell me how to apply the patch to the installtion?
Comment 6 Robert G. 'Doc' Savage 2004-07-19 18:29:16 EDT
My 2000S ZCR card is the Ultra160 predecessor to Tom Sommer's U320
2010S ZCR. I'm having the same problem at Tom on a Tyan S2468UGN with
dual LSI / Symbios 53C1010-33 U160 channels. The i2o_proc.ko driver
from the 586 RPM simply refuses to load at step 4 and allow me to see
the drives (they show up fine under RHEL3 using the old dpt_i2o
driver). Once in a while I get the following in the ALT-F4 error log:
<4>i2o_proc: Unknown symbol i2o_install_handler
<4>i2o_proc: Unknown symbol i2o_query_scalar
<4>i2o_proc: Unknown symbol i2o_remove_handler
<4>i2o_proc: Unknown symbol i2o_find_controller
<4>i2o_proc: Unknown symbol i2o_device_notify_on
<4>i2o_proc: Unknown symbol i2o_unlock_controller
<4>i2o_proc: Unknown symbol i2o_status_get
<4>i2o_proc: Unknown symbol i2o_query_table
<4>i2o_proc: Unknown symbol i2o_get_class_name
<4>i2o_proc: Unknown symbol i2o_device_notify_off
I've got the patch. Like Tom, I could use a thumbnail refresher on how
to apply it & recompile on an FC1 system.
Comment 7 Tom Sommer 2004-07-19 18:32:50 EDT
It should be noted that the new 2.6.7 Kernel contains valid and usable
device drivers for the above mentioned controller.
Comment 8 Stas 2004-07-23 01:44:00 EDT
Hi. Sorry my english not so good.
I have a trable. I trying insalled FC2 on system whith RAID adapter 
Adaptec 2010S. And doing how described here -> 
http://www.redhat.com/archives/fedora-list/2004-May/msg03906.html
I copyig i2o_proc.ko from floppy to /tmp, then I do 
#insmod i2o_proc.ko. But module not loaded :-(
Comment 9 Robert G. 'Doc' Savage 2004-07-23 23:41:06 EDT
Question for Warren:

Even if the patch fixes the "won't load" problem for ZCR cards, we
won't be able to boot our systems after the installation. It's been a
long time since an errata CD#1 was issued, but it seems to me that's
the only way for ZCR users would be able to install and use FC2.

Right now I'm trying to decide between FC1 and RCEL3/ES. Should I give
up on FC2?
Comment 10 Warren Togami 2004-07-24 04:30:26 EDT
RHEL3 should support your card using the old dpt_i2o driver in the 2.4
kernel.  Theoretically that is.  I am not sure if that driver is
included in RHEL3 or not.  FC1 should also theoretically support it
with its 2.4 kernel.

http://i2o.shadowconnect.com/download.php
FC2 would be very difficult to install becuase you would need to use a
custom build with appropriate patches from here.  I don't know exactly
which patches are needed on the latest upstream or fedora kernel.  I
would suggest waiting for FC3 test2 which should be able to install
directly from the CD's.  Well, that is if we manage to convince
upstream kernel to commit Markus' latest patches, and the installer is
fixed to autodetect the drives.
Comment 11 Robert G. 'Doc' Savage 2004-07-24 08:24:52 EDT
I can confirm that RHEL3 does support my Adaptec 2000S card. At least
Disk Druid on CD#1 can see my system drive and RAID array. (Arghh! The
power supply just failed :-( so I can't check FC1. I think I'll wait
for FC3t2. Maybe mid-August do you think??)
Comment 12 Dave 2004-08-01 07:34:23 EDT
Not just another "me too" post, but I am in the same situation. I do
however have machines with both "zero channel" and "standalone 2100S"
devices to test with, so if something starts to shake, I can test on
both platforms.
Comment 13 Warren Togami 2004-08-31 22:44:22 EDT
Rawhide on September 1st should be installable on i2o.  You will need
minimally:
kudzu-1.1.84-1
kernel-2.6.8-1.534

I too will test a network install from boot.iso when tomorrow's
rawhide hits.
Comment 14 Robert G. 'Doc' Savage 2004-10-25 23:25:18 EDT
FC3t3 appears to be fixed. I had to pick the i2o_block driver before
proceeding to the manual partitioning screen, but once there I was
able to see all the existing partitions set up under the old dpt_i2o
driver in RHEL3/ES. I dared not go any further for fear of damaging a
known good production system. You can probably put a "fixed" checkmark
by the Adaptec 2000S zero channel raid card. Good show.
Comment 15 Warren Togami 2004-10-25 23:51:19 EDT
Please re-test with the FC3 release candidate.
http://testing.fedora.redhat.com/tree/

We need to know if the newer kernel here correctly autodetects your
card, rather than needing to select the driver manually.
Comment 16 Dave Jones 2005-04-16 00:57:45 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.