Bug 1235688 (CVE-2015-4706, CVE-2015-4707) - CVE-2015-4706 CVE-2015-4707 ipython: IPython 3.2 contains important security fixes
Summary: CVE-2015-4706 CVE-2015-4707 ipython: IPython 3.2 contains important security ...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2015-4706, CVE-2015-4707
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20150621,repor...
Depends On: 1235690 1235691
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-25 13:48 UTC by Vasyl Kaigorodov
Modified: 2019-06-08 20:38 UTC (History)
7 users (show)

Fixed In Version: IPython 3.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-27 18:31:08 UTC


Attachments (Terms of Use)

Description Vasyl Kaigorodov 2015-06-25 13:48:44 UTC
From http://ipython.org/ipython-doc/3/whatsnew/version3.html :

IPython 3.2 contains important security fixes. Users are strongly encouraged to upgrade immediately.

Highlights:

    A security improvement that set the secure attribute to login cookie to prevent them to be sent over http
    Revert the face color of matplotlib axes in the inline backend to not be transparent.
    Enable mathjax safe mode by default
    Fix XSS vulnerability in JSON error messages
    Various widget-related fixes

See Issues closed in the 3.x development cycle for details:
https://github.com/ipython/ipython/issues?utf8=%E2%9C%93&q=milestone%3A3.2+is%3Aclosed+

Comment 1 Vasyl Kaigorodov 2015-06-25 13:49:08 UTC
Created ipython tracking bugs for this issue:

Affects: fedora-all [bug 1235690]
Affects: epel-all [bug 1235691]

Comment 2 Fedora Update System 2015-07-31 18:33:05 UTC
ipython-3.2.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.