Bug 123576 - improper filename formating for rhel 3WS/ES update 2 ISO Download
improper filename formating for rhel 3WS/ES update 2 ISO Download
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Stable
All Linux
high Severity high
: ---
: ---
Assigned To: Shannon Hughes
Fanny Augustin
:
Depends On:
Blocks: 123188
  Show dependency treegraph
 
Reported: 2004-05-19 09:42 EDT by Chris Stankaitis
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 13:55:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Stankaitis 2004-05-19 09:42:01 EDT
Description of problem:

Try to wget or curl the ISO's for RHEL-3WS or RHEL-3ES Update 2 and
encounter problems.

using wget or curl file name for update2 iso's are not being formated
properly.

file name shows up as

rhel-3-U2-i386-ws-disc1.iso?auth=%2F1085059962%2F5dd77a46652c8c7e9722b4ac58f0bdc3cadb2f08%2F1011499%2F9282

and 

rhel-3-U2-i386-es-disc1.iso?auth=%2F1085060217%2F5ba75f407a8633f6dbca2aa26fb4b3217fb6b05b%2F1011499%2F9270

rather then the proper (just the stuff pre .iso) name
tested wget and curl with RHEL-3WS/ES Update 1 and filename is proper.


Steps to Reproduce:
1. wget or curl the copied link to update 2
2. observe the long wrong file name 
3. wget or curl the copied link to update 1 
4. observe the nromal filename
  
Expected results:

update 2 should download from RHN with proper filenames
Comment 1 Chris Stankaitis 2004-06-21 12:52:35 EDT
Been over a month, and still an issue, please confirm and fix.
Comment 2 Matt Jamison 2004-06-21 15:52:45 EDT
yep, it's doing that.

-rw-r--    1 jamisonm jamisonm  6618624 Jun 21 15:48
rhel-3-U2-i386-as-disc1.iso?auth=%2F1087933451%2F6b8d5e4b33119cd167edffc6b4bf508c8b64e5f4%2F907803%2F9247.1


over to robin to fix.
Comment 3 Todd Warner 2004-06-22 10:03:14 EDT
Ok... works fine from a browser, but not so good from wget or curl.
Ugh.

Linking it to a release so the bug is more prominent. Reprioritze as
you see fit.
Comment 4 Robin Norwood 2004-07-13 16:56:44 EDT
This is deferred to rhn360hosted.
Comment 5 Shannon Hughes 2004-10-11 16:35:41 EDT
*Akami requires us to use a specific url format for downloading isos.
the get parameters used by Akami are causing curl to include as the
filename on the client due to the -O option that is currently messaged
to the user:

Once curl is installed, at a shell prompt, cut and paste the URL for
the ISO into the curl command as follows:

[user@localhost home]$ curl -C - -O 'very_long_url'

*Adding additional messaging to inform user the capability of
selecting a custom name:

Use the following curl command to save the iso as 'myfilename.iso':

[user@localhost home]$ curl -C - -o 'myfilename.iso' 'very_long_url'
Comment 6 Todd Warner 2004-10-21 12:58:24 EDT
QA push. {ON_DEV,QA_READY} --> ON_QA
Comment 7 Fanny Augustin 2004-10-27 15:35:23 EDT
Please provide a test plan.
Comment 8 Shannon Hughes 2004-10-27 15:46:11 EDT
qa plan, 

very simple test...go to the iso download page and copy a iso url then
proceed to commment 5 i.e. curl -C - -o 'myfilename.iso' 'very_long_url'

veryify that myfilename.iso was downloaded. 

Comment 9 Todd Warner 2004-10-28 15:11:13 EDT
ON_DEV/QA_READY --> ON_QA (webQA and RHN Sat ISO/package push complete)
Comment 10 Todd Warner 2004-10-28 15:58:07 EDT
ON_DEV/QA_READY --> ON_QA (webQA and RHN Sat ISO/package push complete) REALLY!
Comment 11 Fanny Augustin 2004-10-31 12:48:00 EST
Looks good on QA.
Comment 12 Clay Murphy 2004-12-03 14:54:34 EST
docs complete
Comment 13 Todd Warner 2005-03-22 13:55:41 EST
Mass move from PROD_READY to CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.