Bug 1235820 - The default for NeutronNetworkVLANRanges is set to datacentre:1000 which is not valid.
Summary: The default for NeutronNetworkVLANRanges is set to datacentre:1000 which is n...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin
Version: Director
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ga
: Director
Assignee: John Trowbridge
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-25 20:08 UTC by John Trowbridge
Modified: 2015-08-05 13:56 UTC (History)
8 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:56:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 237661 None None None Never
Gerrithub.io 237700 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description John Trowbridge 2015-06-25 20:08:10 UTC
Description of problem:

NeutronNetworkVLANRanges must be a range

I am not sure why this was not previously a problem, but my
deployments have been failing on Neutron failing to start.
I eventually traced the issue to:

2015-06-25 13:06:35.612 14675 TRACE
neutron.plugins.ml2.drivers.type_vlan
NetworkVlanRangeError: Invalid network VLAN range:
'datacentre:1000' - 'need more than 2 values to unpack'

Making the default value for this a "range" with the single
VLAN 1000, got me to a successful deploy.

https://review.gerrithub.io/237661

Version-Release number of selected component (if applicable):
python-rdomanager-oscplugin-0.0.8-10.el7ost.noarch

How reproducible:
100% for me today, but oddly never hit this before.

Steps to Reproduce:
1. 1 control 1 compute virt install with no changes to the default network configuration

Actual results:
Deployment fails with the following in /var/log/neutron/server.log on the controller:
2015-06-25 13:06:35.612 14675 TRACE
neutron.plugins.ml2.drivers.type_vlan
NetworkVlanRangeError: Invalid network VLAN range:
'datacentre:1000' - 'need more than 2 values to unpack'

Expected results:
Deployment succeeds

Comment 3 John Trowbridge 2015-06-26 13:15:22 UTC
While this default keeps neutron from failing to start, it is pretty useless if you actually intend to use VLAN tenant networks.

Posted a fix upstream:
https://review.gerrithub.io/237700

Comment 7 Eran Kuris 2015-06-29 13:36:05 UTC
Verified on $ rpm -qa |grep python-rdomanager
python-rdomanager-oscplugin-0.0.8-13.el7ost.noarch
 
latest puddle of :  RHEL-OSP director puddle 7.0 RC - 2015-06-26.3

checked ml2  conf to verify vlan ranges:

[stack@instack ~]$ sudo vi /etc/neutron/plugins/ml2/ml2_conf.ini 
# network_vlan_ranges =
network_vlan_ranges =physnet1:1000:2999
# Example: network_vlan_ranges = physnet1:1000:2999,physnet2

Comment 8 Eran Kuris 2015-06-29 13:52:31 UTC
[heat-admin@overcloud-controller-0 ~]$ sudo grep 1000 /etc/neutron/plugins/ml2/ml2_conf.ini
network_vlan_ranges =datacentre:1:1000
# Example: network_vlan_ranges = physnet1:1000:2999,physnet2
tunnel_id_ranges =1:1000
vni_ranges =1:1000

Comment 10 errata-xmlrpc 2015-08-05 13:56:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.