Bug 1235823 - hammer respository-set command name mismatch
Summary: hammer respository-set command name mismatch
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: API
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-25 20:14 UTC by Andrew Schofield
Modified: 2019-11-14 06:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:53:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Andrew Schofield 2015-06-25 20:14:59 UTC
Description of problem:

The name of the repository set passed via hammer and the name displayed by hammer are different (arch & release are appended):

# hammer repository-set available-repositories --product "Red Hat Enterprise Linux Server" --name "Red Hat Enterprise Linux 6 Server (RPMs)" --organization-id 3
------------------------------------------------------|--------|---------|--------
NAME                                                  | ARCH   | RELEASE | ENABLED
------------------------------------------------------|--------|---------|--------
Red Hat Enterprise Linux 6 Server RPMs i386 6.1       | i386   | 6.1     | no
Red Hat Enterprise Linux 6 Server RPMs x86_64 6.1     | x86_64 | 6.1     | no
Red Hat Enterprise Linux 6 Server RPMs i386 6.2       | i386   | 6.2     | no
Red Hat Enterprise Linux 6 Server RPMs x86_64 6.2     | x86_64 | 6.2     | no
Red Hat Enterprise Linux 6 Server RPMs i386 6.3       | i386   | 6.3     | no
Red Hat Enterprise Linux 6 Server RPMs x86_64 6.3     | x86_64 | 6.3     | no
Red Hat Enterprise Linux 6 Server RPMs i386 6.4       | i386   | 6.4     | no
Red Hat Enterprise Linux 6 Server RPMs x86_64 6.4     | x86_64 | 6.4     | no
Red Hat Enterprise Linux 6 Server RPMs i386 6.5       | i386   | 6.5     | no
Red Hat Enterprise Linux 6 Server RPMs x86_64 6.5     | x86_64 | 6.5     | no
Red Hat Enterprise Linux 6 Server RPMs i386 6.6       | i386   | 6.6     | no
Red Hat Enterprise Linux 6 Server RPMs x86_64 6.6     | x86_64 | 6.6     | no
Red Hat Enterprise Linux 6 Server RPMs i386 6Server   | i386   | 6Server | no
Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server | x86_64 | 6Server | yes
------------------------------------------------------|--------|---------|--------

The name displayed should be 'Red Hat Enterprise Linux 6 Server RPMs' arch and release information are in their respective columns.

Version-Release number of selected component (if applicable):
6.1 public beta.

How reproducible:
Always,

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 RHEL Program Management 2015-06-25 20:22:33 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Brad Buckingham 2015-09-25 17:53:08 UTC
Created redmine issue http://projects.theforeman.org/issues/11968 from this bug

Comment 4 Bryan Kearney 2015-09-25 18:03:15 UTC
Upstream bug component is Content Management

Comment 5 Brad Buckingham 2015-09-25 18:13:54 UTC
The solution for this bugzilla is contained within 2 PRs.  They are:

https://github.com/Katello/katello/pull/5499
https://github.com/Katello/hammer-cli-katello/pull/322

With the above, the 'available-repositories' command should now return a result similar to:

hammer> repository-set available-repositories --product "Red Hat Enterprise Linux Server" --name "Red Hat Enterprise Linux 6 Server (RPMs)" --organization-id 1
-----------------------------------------|--------|---------|---------------|--------
NAME                                     | ARCH   | RELEASE | REGISTRY NAME | ENABLED
-----------------------------------------|--------|---------|---------------|--------
Red Hat Enterprise Linux 6 Server (RPMs) | i386   | 6.1     |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | x86_64 | 6.1     |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | i386   | 6.2     |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | x86_64 | 6.2     |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | i386   | 6.3     |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | x86_64 | 6.3     |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | i386   | 6.4     |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | x86_64 | 6.4     |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | i386   | 6.5     |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | x86_64 | 6.5     |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | i386   | 6.6     |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | x86_64 | 6.6     |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | i386   | 6.7     |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | x86_64 | 6.7     |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | i386   | 6Server |               | no     
Red Hat Enterprise Linux 6 Server (RPMs) | x86_64 | 6Server |               | no     
-----------------------------------------|--------|---------|---------------|--------

Comment 6 Bryan Kearney 2015-10-06 14:03:23 UTC
Upstream bug component is API

Comment 7 Bryan Kearney 2015-10-06 14:03:25 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11968 has been closed
-------------
Brad Buckingham
Applied in changeset commit:hammer-cli-katello|db1c4c35c91448d6f6cd3c15ec98246a651b492f.

Comment 8 Tazim Kolhar 2015-11-23 06:42:08 UTC
VERIFIED:
# rpm -qa | grep foreman
hp-dl360g7-01.lab.eng.brq.redhat.com-foreman-proxy-1.0-1.noarch
foreman-release-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-vmware-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-debug-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-libvirt-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
foreman-postgresql-1.11.0-0.develop.201511161350git860ef06.el7.noarch
hp-dl360g7-01.lab.eng.brq.redhat.com-foreman-proxy-client-1.0-1.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-ovirt-1.11.0-0.develop.201511161350git860ef06.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
foreman-proxy-1.11.0-0.develop.201511161424gitf24be74.el7.noarch
foreman-compute-1.11.0-0.develop.201511161350git860ef06.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
hp-dl360g7-01.lab.eng.brq.redhat.com-foreman-client-1.0-1.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201511111650gitdda13df.el7.noarch
foreman-gce-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-release-scl-1-1.el7.x86_64
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch



steps:
# hammer repository-set available-repositories --product "Red Hat Enterprise Linux Server" --name "Red Hat Enterprise Linux 6 Server (RPMs)" --organization-id 1
[Foreman] Password for admin: 
------------------------------------------------------|--------|---------|---------------|--------
NAME                                                  | ARCH   | RELEASE | REGISTRY NAME | ENABLED
------------------------------------------------------|--------|---------|---------------|--------
Red Hat Enterprise Linux 6 Server RPMs i386 6.1       | i386   | 6.1     |               | no     
Red Hat Enterprise Linux 6 Server RPMs x86_64 6.1     | x86_64 | 6.1     |               | no     
Red Hat Enterprise Linux 6 Server RPMs i386 6.2       | i386   | 6.2     |               | no     
Red Hat Enterprise Linux 6 Server RPMs x86_64 6.2     | x86_64 | 6.2     |               | no     
Red Hat Enterprise Linux 6 Server RPMs i386 6.3       | i386   | 6.3     |               | no     
Red Hat Enterprise Linux 6 Server RPMs x86_64 6.3     | x86_64 | 6.3     |               | no     
Red Hat Enterprise Linux 6 Server RPMs i386 6.4       | i386   | 6.4     |               | no     
Red Hat Enterprise Linux 6 Server RPMs x86_64 6.4     | x86_64 | 6.4     |               | no     
Red Hat Enterprise Linux 6 Server RPMs i386 6.5       | i386   | 6.5     |               | no     
Red Hat Enterprise Linux 6 Server RPMs x86_64 6.5     | x86_64 | 6.5     |               | no     
Red Hat Enterprise Linux 6 Server RPMs i386 6.6       | i386   | 6.6     |               | no     
Red Hat Enterprise Linux 6 Server RPMs x86_64 6.6     | x86_64 | 6.6     |               | no     
Red Hat Enterprise Linux 6 Server RPMs i386 6.7       | i386   | 6.7     |               | no     
Red Hat Enterprise Linux 6 Server RPMs x86_64 6.7     | x86_64 | 6.7     |               | no     
Red Hat Enterprise Linux 6 Server RPMs i386 6Server   | i386   | 6Server |               | no     
Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server | x86_64 | 6Server |               | no     
------------------------------------------------------|--------|---------|---------------|--------

Comment 12 errata-xmlrpc 2016-07-27 08:53:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.