Bug 1235836 - Overcloud horizon does not has 'Create Network' button under project tab
Summary: Overcloud horizon does not has 'Create Network' button under project tab
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ga
: Director
Assignee: Mike Burns
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-25 21:04 UTC by Ido Ovadia
Modified: 2015-08-05 13:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:56:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
Create Network is missing (77.48 KB, image/png)
2015-06-25 21:04 UTC, Ido Ovadia
no flags Details
neutronpolicy file (7.33 KB, text/plain)
2015-06-26 11:00 UTC, Ido Ovadia
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ido Ovadia 2015-06-25 21:04:53 UTC
Created attachment 1043292 [details]
Create Network is missing

Description of problem:
=======================
Overcloud horizon does not has 'Create Network' button under 
Project > Network > Networks 

Version-Release number of selected component:
=============================================
openstack-dashboard-2015.1.0-10.el7ost.noarch
python-django-horizon-2015.1.0-10.el7ost.noarch

How reproducible:
=================
100%

Steps to Reproduce:
===================
1. Deploy overcloud
2. Log in to overcloud UI  Horizon
3. Go to Project -> Network -> Networks

Actual results:
===============
There is no 'Create Network' button

Expected results:
=================
Button shold exist

Additional info:
================
Sceenshot is enclosed

Comment 15 Matthias Runge 2015-06-26 09:14:50 UTC
since it's possible to disable creating networks, we'll need the policy file from /etc/openstack-dashboard

I suspect a setup issue, as this definitely works, when installing via packstack.

Comment 18 Matthias Runge 2015-06-26 10:53:08 UTC
I could reproduce such a situation by removing my cinder v2 endpoint.
I suspect this to be a duplicate of bug 1233945

Comment 21 Ido Ovadia 2015-06-26 11:00:48 UTC
Created attachment 1043469 [details]
neutronpolicy file

Comment 24 Lon Hohberger 2015-06-26 13:51:24 UTC
Confirming comment #15 - tested with AIO packstack.

Comment 29 Ido Ovadia 2015-06-28 11:12:10 UTC
This bug occurs while installing by OSP-7 director,
It doesn't happen using packstack

Comment 32 Matthias Runge 2015-06-28 14:21:01 UTC
Thi sshould be a duplicate of bug 1233956, moving to diretor.

Comment 35 Ido Ovadia 2015-06-29 12:50:36 UTC
Verified
========
os-cloud-config-0.2.8-4.el7ost.noarch
python-django-horizon-2015.1.0-10.el7ost.noarch

Comment 36 Scott Lewis 2015-06-30 14:14:55 UTC
adding pm_ack+ for TestOnly bug that's already verified

Comment 38 errata-xmlrpc 2015-08-05 13:56:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.