Bug 1235844 - Overcloud horizon does not has 'Create Router' button under project tab
Summary: Overcloud horizon does not has 'Create Router' button under project tab
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 7.0 (Kilo)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: Director
Assignee: Mike Burns
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
: 1233644 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-25 21:31 UTC by Ido Ovadia
Modified: 2016-04-18 06:50 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:56:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
Create Router is missing (68.71 KB, image/png)
2015-06-25 21:31 UTC, Ido Ovadia
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ido Ovadia 2015-06-25 21:31:15 UTC
Created attachment 1043308 [details]
Create Router is missing

Description of problem:
=======================
Overcloud horizon does not has 'Create Router' button under 
Project -> Network -> Routers


Version-Release number of selected component (if applicable):
=============================================================
openstack-dashboard-2015.1.0-10.el7ost.noarch
python-django-horizon-2015.1.0-10.el7ost.noarch

How reproducible:
=================
100%

Steps to Reproduce:
===================
1. Deploy overcloud
2. Log in to overcloud UI  Horizon
3. Go to Project -> Network -> Routers

Actual results:
===============
'Create Router' button is missing

Expected results:
=================
'Create Router' button should exist

Additional info:
================
Screenshot is enclosed

Comment 2 Lon Hohberger 2015-06-26 13:53:17 UTC
This works when deployed via AIO packstack.  It may be some sort of configuration or deployment issue.

Comment 3 Ido Ovadia 2015-06-28 11:10:09 UTC
This bug occurs while installing by OSP-7 director,
It doesn't happen using packstack

Comment 4 Matthias Runge 2015-06-28 14:29:41 UTC
I can reproduce this issue when removing th evolumev2 endpoint from setup. This is director issue bug 1233956.

The tracker for horizon to support cinder volume v1 only is bug 1233945

Comment 5 Ido Ovadia 2015-06-29 12:55:15 UTC
Verified
========
os-cloud-config-0.2.8-4.el7ost.noarch
python-django-horizon-2015.1.0-10.el7ost.noarch

Comment 6 Scott Lewis 2015-06-30 14:14:56 UTC
adding pm_ack+ for TestOnly bug that's already verified

Comment 8 errata-xmlrpc 2015-08-05 13:56:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549

Comment 9 Matthias Runge 2015-08-20 12:38:58 UTC
*** Bug 1233644 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.