Bug 1235875 - Failed to launch an instance from Overcloud Horizon
Summary: Failed to launch an instance from Overcloud Horizon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 7.0 (Kilo)
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ga
: Director
Assignee: Mike Burns
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-26 01:04 UTC by Ido Ovadia
Modified: 2016-04-18 06:50 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:56:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ido Ovadia 2015-06-26 01:04:20 UTC
Description of problem:
=======================
Horizon failed to launch an instance and return Danger error 

Version-Release number of selected component (if applicable):
=============================================================
openstack-dashboard-2015.1.0-10.el7ost.noarch
python-django-horizon-2015.1.0-10.el7ost.noarch

How reproducible:
=================
100%

Steps to Reproduce:
===================
1. Click Project -> Compute -> Instances
2. Click Launch Instance
3. Fill details and click Launch

Actual results:
===============
Failed to launch instance and error:
"Danger: There was an error submitting the form. Please try again"


Expected results:
=================
Instance Launch successfully

Additional info:

Comment 2 Matthias Runge 2015-06-26 07:18:11 UTC
Do you have logs? E.g. nova logs?

Since this behaviour differs from packstack deployments, I would expect an installer issue here. Did you install via osp-director? does nova boot ...work in that setup? Is the setup still available?

Comment 3 Lon Hohberger 2015-06-26 13:58:02 UTC
This is working from packstack; I just launched a cirros from the webui.

Comment 4 Ido Ovadia 2015-06-28 10:58:58 UTC
horizon.log
============
2015-06-28 10:47:31,988 2691 ERROR django.request Internal Server Error: /dashboard/project/instances/launch
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/django/core/handlers/base.py", line 132, in get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/decorators.py", line 36, in dec
    return view_func(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/decorators.py", line 52, in dec
    return view_func(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/decorators.py", line 36, in dec
    return view_func(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/decorators.py", line 84, in dec
    return view_func(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/django/views/generic/base.py", line 71, in view
    return self.dispatch(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/django/views/generic/base.py", line 89, in dispatch
    return handler(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/workflows/views.py", line 167, in post
    context = self.get_context_data(**kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/workflows/views.py", line 91, in get_context_data
    workflow = self.get_workflow()
  File "/usr/lib/python2.7/site-packages/horizon/workflows/views.py", line 81, in get_workflow
    entry_point=entry_point)
  File "/usr/lib/python2.7/site-packages/horizon/workflows/base.py", line 648, in __init__
    valid = step.action.is_valid()
  File "/usr/lib/python2.7/site-packages/django/forms/forms.py", line 184, in is_valid
    return self.is_bound and not self.errors
  File "/usr/lib/python2.7/site-packages/django/forms/forms.py", line 176, in errors
    self.full_clean()
  File "/usr/lib/python2.7/site-packages/django/forms/forms.py", line 393, in full_clean
    self._clean_form()
  File "/usr/lib/python2.7/site-packages/django/forms/forms.py", line 417, in _clean_form
    cleaned_data = self.clean()
  File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/dashboards/project/instances/workflows/create_instance.py", line 357, in clean
    self._check_quotas(cleaned_data)
  File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/dashboards/project/instances/workflows/create_instance.py", line 209, in _check_quotas
    usages = quotas.tenant_quota_usages(self.request)
  File "/usr/lib/python2.7/site-packages/horizon/utils/memoized.py", line 90, in wrapped
    value = cache[key] = func(*args, **kwargs)
  File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/usage/quotas.py", line 349, in tenant_quota_usages
    tenant_id=tenant_id):
  File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/usage/quotas.py", line 165, in get_tenant_quota_data
    tenant_id=tenant_id)
  File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/usage/quotas.py", line 147, in _get_quota_data
    quotasets.append(getattr(cinder, method_name)(request, tenant_id))
  File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/api/cinder.py", line 409, in tenant_quota_get
    return base.QuotaSet(c_client.quotas.get(tenant_id))
  File "/usr/lib/python2.7/site-packages/cinderclient/v2/quotas.py", line 37, in get
    "quota_set")
  File "/usr/lib/python2.7/site-packages/cinderclient/base.py", line 149, in _get
    resp, body = self.api.client.get(url)
  File "/usr/lib/python2.7/site-packages/cinderclient/client.py", line 302, in get
    return self._cs_request(url, 'GET', **kwargs)
  File "/usr/lib/python2.7/site-packages/cinderclient/client.py", line 269, in _cs_request
    **kwargs)
  File "/usr/lib/python2.7/site-packages/cinderclient/client.py", line 239, in request
    **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/api.py", line 50, in request
    response = session.request(method=method, url=url, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 451, in request
    prep = self.prepare_request(req)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 382, in prepare_request
    hooks=merge_hooks(request.hooks, self.hooks),
  File "/usr/lib/python2.7/site-packages/requests/models.py", line 304, in prepare
    self.prepare_url(url, params)
  File "/usr/lib/python2.7/site-packages/requests/models.py", line 362, in prepare_url
    to_native_string(url, 'utf8')))
MissingSchema: Invalid URL '/os-quota-sets/9771fedffefc4b9a811e652b947eac31?usage=False': No schema supplied. Perhaps you meant http:///os-quota-sets/9771fedffefc4b9a811e652b947eac31?usage=False?

Comment 5 Ido Ovadia 2015-06-28 11:08:45 UTC
This bug occurs while installing by OSP-7 director,
It doesn't happen using packstack

Comment 6 Matthias Runge 2015-06-28 14:32:50 UTC
I can reproduce this issue when removing the volumev2 endpoint from setup. This is director issue bug 1233956.

The tracker for horizon to support cinder volume v1 only is bug 1233945

Comment 7 Ido Ovadia 2015-06-29 12:53:04 UTC
Verified
========
os-cloud-config-0.2.8-4.el7ost.noarch
python-django-horizon-2015.1.0-10.el7ost.noarch

Comment 8 Scott Lewis 2015-06-30 14:14:56 UTC
adding pm_ack+ for TestOnly bug that's already verified

Comment 10 errata-xmlrpc 2015-08-05 13:56:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.