Bug 123594 - [PATCH] traceback when installing packages that require kernel packages
Summary: [PATCH] traceback when installing packages that require kernel packages
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: up2date-rhel3-u3
TreeView+ depends on / blocked
 
Reported: 2004-05-19 15:20 UTC by Elliot Peele
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 01:32:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes bug (11.90 KB, patch)
2004-05-20 04:11 UTC, Elliot Peele
no flags Details | Diff
patch for beter arch selection in genericSolveDep (1.51 KB, patch)
2004-06-10 20:44 UTC, Adrian Likins
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:367 normal SHIPPED_LIVE Updated up2date packages 2004-08-02 04:00:00 UTC

Description Elliot Peele 2004-05-19 15:20:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
When trying to install a package that requires kernel-unsupported I
get a traceback saying that package kernel-unsupported is intended for
a athlon architecture. I have tried this on two systems with the same
result. IIRC, this worked correctly before U2.

[root@rkbuild root]# up2date -u autofs
                                                                     
                    
Fetching package list for channel: rhel-i386-ws-3...
########################################
                                                                     
                    
Fetching package list for channel: rhel-i386-ws-3-extras...
########################################
                                                                     
                    
Fetching package list for channel: rhel-i386-ws-3-devsuite...
########################################
                                                                     
                    
Fetching package list for channel: realmlinux-ws3...
########################################
                                                                     
                    
Fetching package list for channel: physics...
                                                                     
                    
Fetching
http://install.linux.ncsu.edu/pub/yum/astro/physics-WS3/headers/header.info...
########################################
                                                                     
                    
Fetching Obsoletes list for channel: rhel-i386-ws-3...
                                                                     
                    
Fetching Obsoletes list for channel: rhel-i386-ws-3-extras...
                                                                     
                    
Fetching Obsoletes list for channel: rhel-i386-ws-3-devsuite...
                                                                     
                    
Fetching Obsoletes list for channel: realmlinux-ws3...
                                                                     
                    
Fetching Obsoletes list for channel: physics...
                                                                     
                    
Fetching rpm headers...
########################################
                                                                     
                    
Name                                    Version        Rel
----------------------------------------------------------
autofs                                  4.1.2          1             
   i386
                                                                     
                    
                                                                     
                    
Testing package set / solving RPM inter-dependencies...
########################################
autofs-4.1.2-1.i386.rpm:    ########################## Done.
kernel-unsupported-2.4.21-1 ########################## Done.
Preparing              ########################################### [100%]
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1174, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 772, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1066, in batchRun
    batch.run()
  File "up2dateBatch.py", line 84, in run
  File "up2dateBatch.py", line 165, in __installPackages
  File "up2date.py", line 692, in installPackages
  File "up2date.py", line 580, in runTransaction
  File "rpmUtils.py", line 491, in runTransaction
up2date_client.up2dateErrors.TransactionError: RPM  error. The message
was:
Failed running transaction of  packages:
('package kernel-unsupported-2.4.21-15.EL is intended for a athlon
architecture', (0, 'athlon', 0L))


Version-Release number of selected component (if applicable):
4.2.16-1

How reproducible:
Always

Steps to Reproduce:
1. make package that requires a kernel package that isn't already
installed
2. try to install package using up2date
3.
    

Actual Results:  traceback and no install

Expected Results:  should install the correct kernel-unsupported package

Additional info:

*sigh*

Comment 1 Elliot Peele 2004-05-19 22:13:01 UTC
This works in 4.2.5 but not in 4.2.14 or 4.2.16.

Comment 2 Elliot Peele 2004-05-20 04:11:59 UTC
Created attachment 100367 [details]
Patch that fixes bug

This may cause some other problems. I also fixed the tabs so that everything is
now spaces in genericSolveDep.py.

Comment 3 Adrian Likins 2004-05-24 22:02:00 UTC
heh, somehow I knew that multilib change was too complicated...

Comment 4 Adrian Likins 2004-06-10 19:16:22 UTC
taking a look now..

the tab/space/whatever changes added a lot of noise
to the patch, but the biggest problem is I refactored
that code since then...

course the refactors stuff doesnt quite work yet
either... but I'll see what I can do

Comment 5 Adrian Likins 2004-06-10 20:43:16 UTC
try the attached patch and see if that behaves for you...


Comment 6 Adrian Likins 2004-06-10 20:44:36 UTC
Created attachment 101046 [details]
patch for beter arch selection in genericSolveDep

Comment 7 Elliot Peele 2004-06-10 21:24:01 UTC
seens to work

Comment 8 Elliot Peele 2004-06-10 21:24:43 UTC
seems that is

Comment 9 Adrian Likins 2004-06-10 22:24:32 UTC
reverted the refactor and applied that patch
lands in 4.2.22-1

Comment 10 Jay Turner 2004-08-03 01:32:35 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-367.html



Note You need to log in before you can comment on or make changes to this bug.