Bug 1235942 - Standalone debugger can't be started
Summary: Standalone debugger can't be started
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-cdt
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Jeff Johnston
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-26 07:15 UTC by Alexander Kurtakov
Modified: 2016-01-27 08:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-27 08:11:49 UTC


Attachments (Terms of Use)
Still failing error log (204.05 KB, text/plain)
2015-06-29 17:43 UTC, Alexander Kurtakov
no flags Details

Description Alexander Kurtakov 2015-06-26 07:15:38 UTC
Trying to launch it gives just the generic launcher error dialog.
There is nothing in ~/fcdtdebugger and the datadir ~/workspace-fcdtdebug is not created. 
Most probably the problem lies in http://pkgs.fedoraproject.org/cgit/eclipse-cdt.git/tree/eclipse-cdt.spec#n271 - it has to be automated as listing/symlinking bundles that way is too errorprone.

Comment 1 Jeff Johnston 2015-06-26 21:16:51 UTC
Actually a problem was that the libhover patch removed the application of patch3 which has to do with the config.ini file.  The patch also needed a fix to work as the config.ini file added some needed plug-ins for this release that weren't in the patch.  I have not tested the patch works.  It will be in build eclipse-cdt-8.7.0-4 which has just been started.

Comment 2 Alexander Kurtakov 2015-06-29 17:43:53 UTC
Created attachment 1044430 [details]
Still failing error log

Comment 3 Jeff Johnston 2015-06-29 22:41:06 UTC
More improvements.  Some OSGI names had changed for F23 and had to be fixed in the config.ini (javax.servlet, javax.el, and lucene analyzer)

See eclipse-cdt-8.7.0-5

Comment 4 Alexander Kurtakov 2015-06-30 04:14:05 UTC
Works with that build but this have to be automated as current state is too fragile.

Comment 5 Jeff Johnston 2015-06-30 16:39:42 UTC
I'd be interested in how you intend on automating this.  Every package can have some arbitrary OSGI tag it gives.  That is the problem.  The config.ini file has to patch these additional names.  It would be nice to just have the same config.ini file work in Fedora (i.e. packages are referred to by the same name as they are when Eclipse is downloaded).

Comment 6 Jan Kurik 2015-07-15 13:54:47 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 23 development cycle.
Changing version to '23'.

(As we did not run this process for some time, it could affect also pre-Fedora 23 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 23 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora23

Comment 7 Alexander Kurtakov 2016-01-27 08:11:49 UTC
Mark as closed as time not permit further investigation in automation.


Note You need to log in before you can comment on or make changes to this bug.