Bug 1235994 - Tuskar deployments default to a Ceph scale of 1
Summary: Tuskar deployments default to a Ceph scale of 1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-image-elements
Version: Director
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ga
: Director
Assignee: Dougal Matthews
QA Contact: Amit Ugol
URL:
Whiteboard:
: 1233157 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-26 10:01 UTC by Dougal Matthews
Modified: 2015-08-05 13:56 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-image-elements-0.9.6-5.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the default Ceph scale was set to 1, resulting in a Ceph node being created even if the user did not want to create one. With this release, the default Ceph scale setting has been changed to 0. As a result, Ceph is not deployed by default anymore.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:56:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 195965 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Dougal Matthews 2015-06-26 10:01:48 UTC
Description of problem:

Tuskar deployments default to a Ceph scale = 1. It should be 0.


Steps to Reproduce:
1. Do any default deployment with Tuskar
2. or look at 'tuskar plan-show-scale overcloud' after an undercloud install


Actual results:

Ceph has a scale value of 1


Expected results:

EDxpected Ceph to not be enabled by default

Comment 3 Dougal Matthews 2015-06-26 10:03:01 UTC
Fix submitted upstream: https://review.openstack.org/#/c/195965/

Comment 4 Dougal Matthews 2015-06-26 11:21:13 UTC
This can be worked around with:

    tuskar plan-scale -C 0 Ceph-Storage-1 $PLAN_ID

Comment 8 Mike Burns 2015-06-30 11:01:44 UTC
*** Bug 1233157 has been marked as a duplicate of this bug. ***

Comment 10 Amit Ugol 2015-07-06 15:21:53 UTC
unless asked for, Ceph nodes are no longer being created by default.

Comment 12 errata-xmlrpc 2015-08-05 13:56:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.