Bug 1236054 - Keystone cert params are set to '' in tuskar plan
Summary: Keystone cert params are set to '' in tuskar plan
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ga
: Director
Assignee: Lennart Regebro
QA Contact: Mike Abrams
URL:
Whiteboard:
Depends On:
Blocks: 1250246
TreeView+ depends on / blocked
 
Reported: 2015-06-26 12:41 UTC by Jan Provaznik
Modified: 2017-07-10 12:21 UTC (History)
11 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-14.el7ost
Doc Type: Bug Fix
Doc Text:
Cause: Parameters that was created on deployment was not saved in Tuskar. Consequence: Some parameters would default to empty values on stack update or redeploy of a stack. Fix: Save all parameters. Result: Redeploying and updating works as expected.
Clone Of:
: 1250246 (view as bug list)
Environment:
Last Closed: 2015-08-05 13:56:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 237713 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Jan Provaznik 2015-06-26 12:41:02 UTC
Description of problem:
After creating an overcloud plan, it contains empty strings for keystone cert related params:
environment.yaml:  Controller-1::KeystoneCACertificate: ''
environment.yaml:  Controller-1::KeystoneSSLCertificate: ''
environment.yaml:  Controller-1::KeystoneSSLCertificateKey: ''
environment.yaml:  Controller-1::KeystoneSigningCertificate: ''
environment.yaml:  Controller-1::KeystoneSigningKey: ''

If I run stack-update which fetches plan templates from tuskar then stack update fails with:
[stack@instack ~]$ heat stack-list
+--------------------------------------+------------+---------------+----------------------+
| id                                   | stack_name | stack_status  | creation_time        |
+--------------------------------------+------------+---------------+----------------------+
| 360631b9-c6dc-47f0-a46e-3da831b6dbbb | overcloud  | UPDATE_FAILED | 2015-06-26T11:28:03Z |
+--------------------------------------+------------+---------------+----------------------+
[stack@instack ~]$ heat resource-list -n 5 overcloud|grep FAIL
| ControllerNodesPostDeployment               | ccbbba0f-aecb-44cd-bf69-0235b7a2bf97          | OS::TripleO::ControllerPostDeployment             | UPDATE_FAILED   | 2015-06-26T12:07:15Z |                                             |
| ControllerOvercloudServicesDeployment_Step4 | ade3ae55-a245-4202-ab2a-c9f019976eb9          | OS::Heat::StructuredDeployments                   | UPDATE_FAILED   | 2015-06-26T12:09:07Z | ControllerNodesPostDeployment               |
| 0                                           | 1711417c-8bdf-4670-b83a-4be362e18b61          | OS::Heat::StructuredDeployment                    | UPDATE_FAILED   | 2015-06-26T12:09:12Z | ControllerOvercloudServicesDeployment_Step4 |
[stack@instack ~]$ ^C
[stack@instack ~]$ heat deployment-show 1711417c-8bdf-4670-b83a-4be362e18b61
{
  "status": "FAILED", 
  "server_id": "507baf4c-32f9-481a-a269-ffc2cab0a601", 
  "config_id": "b01e1016-d081-4cdd-9023-b8c340e5610d", 
  "output_values": {
    "deploy_stdout": "", 
    "deploy_stderr": "\u001b[1;31mWarning: Scope(Class[Keystone]): Execution of db_sync does not depend on $enabled anymore. Please use sync_db instead.\u001b[0m\n\u001b[1;31mError: Could not find data item keystone_signing_certificate in any Hiera data file and no default supplied at /var/lib/heat-config/heat-config-puppet/b01e1016-d081-4cdd-9023-b8c340e5610d.pp:422 on node overcloud-controller-0.localdomain\u001b[0m\n\u001b[1;31mError: Could not find data item keystone_signing_certificate in any Hiera data file and no default supplied at /var/lib/heat-config/heat-config-puppet/b01e1016-d081-4cdd-9023-b8c340e5610d.pp:422 on node overcloud-controller-0.localdomain\u001b[0m\n", 
    "deploy_status_code": 1
  }, 
  "creation_time": "2015-06-26T11:38:15Z", 
  "updated_time": "2015-06-26T12:10:27Z", 
  "input_values": {}, 
  "action": "UPDATE", 
  "status_reason": "deploy_status_code : Deployment exited with non-zero status code: 1", 
  "id": "1711417c-8bdf-4670-b83a-4be362e18b61"
}


Reproducer:
openstack overcloud deploy --plan $PLAN_UUID
openstack overcloud update stack overcloud --plan overcloud -i

Comment 5 Jan Provaznik 2015-07-22 12:35:32 UTC
No extra steps for creating a plan are required (the overcloud plan is created automatically during "openstack undercloud install" command run)

Comment 6 nlevinki 2015-08-04 11:23:37 UTC
[stack@instack ~]$ openstack overcloud update stack overcloud --plan overcloud -i
starting package update on stack overcloud
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
WAITING
on_breakpoint: [u'overcloud-controller-0', u'overcloud-controller-2', u'overcloud-cephstorage-0', u'overcloud-controller-1', u'overcloud-compute-0']
Breakpoint reached, continue? Regexp or Enter=proceed, no=cancel update, C-c=quit interactive mode:  
removing breakpoint on overcloud-compute-0
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
FAILED
update finished with status FAILED
[stack@instack ~]$ heat stack-list
+--------------------------------------+------------+---------------+----------------------+
| id                                   | stack_name | stack_status  | creation_time        |
+--------------------------------------+------------+---------------+----------------------+
| b1533f7d-f7b3-4118-8f95-0d6c2c51a79e | overcloud  | UPDATE_FAILED | 2015-08-03T08:39:24Z |
+--------------------------------------+------------+---------------+----------------------+
[stack@instack ~]$ heat resource-list -n 5 | egrep -v COMPLETE
usage: heat resource-list [-n <DEPTH>] <NAME or ID>
heat resource-list: error: too few arguments
[stack@instack ~]$ heat resource-list -n 5 overcloud | egrep -v COMPLETE
+---------------------------------------------+-----------------------------------------------+---------------------------------------------------+--------------------+----------------------+---------------------------------------------+
| resource_name                               | physical_resource_id                          | resource_type                                     | resource_status    | updated_time         | parent_resource                             |
+---------------------------------------------+-----------------------------------------------+---------------------------------------------------+--------------------+----------------------+---------------------------------------------+
| Ceph-Storage                                | f4d3d64e-2a2c-4c3e-b039-9a711b9eff92          | OS::Heat::ResourceGroup                           | UPDATE_FAILED      | 2015-08-04T11:04:40Z |                                             |
| 0                                           | a52effbf-6731-4827-bc52-65908c3f3928          | Tuskar::Ceph-Storage-1                            | UPDATE_IN_PROGRESS | 2015-08-04T11:04:42Z | Ceph-Storage                                |
| Compute                                     | 6ab7d712-341f-48d5-94e3-a26ff9fe6043          | OS::Heat::ResourceGroup                           | UPDATE_FAILED      | 2015-08-04T11:05:50Z |                                             |
| 0                                           | 5c483401-cdef-404c-81ac-7cab826ee84c          | Tuskar::Compute-1                                 | UPDATE_FAILED      | 2015-08-04T11:05:52Z | Compute                                     |
| Controller                                  | b00dbc7e-282a-4392-9f22-0f37f538171e          | OS::Heat::ResourceGroup                           | UPDATE_FAILED      | 2015-08-04T11:05:53Z |                                             |
| 0                                           | e8a1478f-3a51-4400-be00-758432bfa93c          | Tuskar::Controller-1                              | UPDATE_IN_PROGRESS | 2015-08-04T11:06:05Z | Controller                                  |
| 2                                           | fecec18d-bbba-4f49-afec-2e5edb1adabd          | Tuskar::Controller-1                              | UPDATE_IN_PROGRESS | 2015-08-04T11:06:20Z | Controller                                  |
| 1                                           | 63dda9be-c496-45c2-8aeb-0f0de6c1e9d8          | Tuskar::Controller-1                              | UPDATE_IN_PROGRESS | 2015-08-04T11:06:50Z | Controller                                  |
| UpdateDeployment                            | 0ab214ba-f01f-4162-b71d-4c16d41da66c          | OS::Heat::SoftwareDeployment                      | UPDATE_FAILED      | 2015-08-04T11:11:51Z | 0                                           |
+---------------------------------------------+-----------------------------------------------+---------------------------------------------------+--------------------+----------------------+---------------------------------------------+
[stack@instack ~]$

Comment 7 Jan Provaznik 2015-08-04 11:33:05 UTC
Can you please paste the reason of failure on UpdateDeployment resource? For the stack it's output of "heat deployment-show 0ab214ba-f01f-4162-b71d-4c16d41da66c".

Comment 10 errata-xmlrpc 2015-08-05 13:56:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.