Bug 123611 - grub hanging in stage 2 upon first boot
grub hanging in stage 2 upon first boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 12:56 EDT by Tom Wood
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 18:21:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of "lspci -v" (2.12 KB, text/plain)
2004-05-19 12:56 EDT, Tom Wood
no flags Details
Contents of /boot/grub/device.map (30 bytes, text/plain)
2004-05-19 12:57 EDT, Tom Wood
no flags Details
MBR zap63 zip file (3.17 KB, application/octet-stream)
2004-11-14 00:50 EST, Sam Griek
no flags Details

  None (edit)
Description Tom Wood 2004-05-19 12:56:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Immediately after installing (not upgrading - full new install) FC2 on
a box that previously ran FC1 and all of the FC2 test releases, grub
hangs loading stage 2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC2
2. Watch grub hang on first boot and every boot thereafter
3.
    

Actual Results:  grub hangs loading stage 2

Expected Results:  Should have booted.

Additional info:

Guessing that anaconda is the culprit here, as running grub-install
after booting from the rescue CD fixed the problem.  Possibly related
to the "Windows-killer" issue? ;-)

Attached please find output from lspci -v and /boot/grub/device.map .
Comment 1 Tom Wood 2004-05-19 12:56:44 EDT
Created attachment 100348 [details]
Output of "lspci -v"
Comment 2 Tom Wood 2004-05-19 12:57:20 EDT
Created attachment 100349 [details]
Contents of /boot/grub/device.map
Comment 3 Axel Thimm 2004-05-25 09:18:02 EDT
The same issue can be observed on a dual-opteron tyan board with PATA
boot drive:

Tyan Thunder K8S Pro S2882G3NR
AMD Opteron 248
2-8GB RAM
Boot disk: 6Y080P0 (80GB Maxtor PATA)

The target system had SuSE preinstalled on /dev/hda1 in a reiserfs
partition (FC2 is on /dev/hda4):

# fdisk -l /dev/hda

Disk /dev/hda: 81.9 GB, 81964302336 bytes
16 heads, 63 sectors/track, 158816 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1       16655     8393931   83  Linux
/dev/hda2           16655       24990     4200997+  82  Linux swap
/dev/hda3           24991       45308    10240272    5  Extended
/dev/hda4           45309      158816    57208032   83  Linux
/dev/hda5           24991       33117     4095976+  82  Linux swap
/dev/hda6   *       33118       45308     6144232+  83  Linux


Tom, did you have an install from scratch, e.g. no old partitions
saved over?

P.S. please change platform to "All"
Comment 4 Tom Wood 2004-05-25 17:44:39 EDT
Yes, this was fresh install.  This box was previously a FC2 test 1/2/3
box.  I tested an upgrade from FC2T3 fully updated, which worked fine,
then ditched that and did a fresh install on the same machine, *but*
(1) I kept the partitions as they were (same size and location, didn't
delete and put them back but used them as they were), *but* (2)
reformatted all system partitions except /home.
Comment 5 Scott McKay 2004-05-25 18:32:29 EDT
I believe I had the same problem. 

Upgrade from FC1 to FC2. Hang during stage2.

I eventually fixed it by copying stage2 from 
/usr/share/grub/i386-redhat/ to /boot/grub/. 

At that time I also updated the System.map, config and vmlinuz links 
in /boot to point to the 2.6.5 files (e.g. System.map -> System.
map-2.6.5-1.358smp). They were pointing to 2.4 files (e.g. System.
map-2.4.???) that no longer existed. Not sure if that was necessary 
though.
Comment 6 Joe Dupre 2004-06-02 15:16:27 EDT
I am observing something similar.  Grub hangs at text prompt "GRUB" 
(prior to loading graphical menu).

Tried copying stage2 as mentioned above, but I get same problem.

This was on a machine that had Windows XP on it.  First install I re-
wrote all partions durring FC2 install.  When I re-booted, I got the 
GRUB prompt followed by a bunch of weird characters.  System hung.

Next I used DOS FDISK to delete all partitions.  Re-installed FC2.  
Now system hangs at the "GRUB" prompt.

Tried grub-install /dev/sda while booted with rescue CD, but that did 
not help.  Then tried copying stage2 as mentioned above but I still 
have the same problem.
Comment 7 Sam Griek 2004-11-13 12:50:14 EST
This same thing happened to me.  I installed Fidora core 3 on a 
machine that had Windows XP and it hung at "loading GRUB stage 2...".

I did use disk druid to delete the xp partition and created a new 
swap and main.  I will let you know how it goes.

Ulcer Sam
Comment 8 Sam Griek 2004-11-14 00:50:57 EST
Created attachment 106660 [details]
MBR zap63 zip file

MBR zap63 program
Comment 9 Sam Griek 2004-11-14 00:53:28 EST
I was able to solve this problem by zapping the MBR and 
reinstalling.  I guess Billy decided to protect his OS's MBR entries 
even after it was removed.

you can find the program I used (zap.exe) to 'fix' the drive by going 
to:

http://www.geocities.com/thestarman3/asm/mbr/BootToolsRefs.htm

download zap63 and put it on a DOS boot disk.  Boot up with the disk 
and run the program.  Reinstall FC3 and you're set!

Worked for me. Good Luck

Ulcer Sam

Comment 10 Jeremy Katz 2005-02-01 18:21:07 EST
Fixed now

Note You need to log in before you can comment on or make changes to this bug.