Bug 123621 - /etc/profile unsets "pathmunge" too early
/etc/profile unsets "pathmunge" too early
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 14:28 EDT by Florin Andrei
Modified: 2015-03-04 20:13 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.5.34-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 07:56:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2004-05-19 14:28:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
In /etc/profile, after a few "pathmunge" statements, that function is
disabled:

unset pathmunge

However, this prevents users and RPM package makers to use the
function in files that get installed in /etc/profile.d

Case in point, i want to set a PATH component for my Java
installation. Since editing /etc/pofile is not nice, and since making
that kind of changes is best accomplished with a new file in
/etc/profile, i'd like to be able to use the pathmunge() function in
my custom file in /etc/profile.d
However, i cannot accomplish that unless i comment out "unset pathmunge".

Version-Release number of selected component (if applicable):
setup-2.5.33-1

How reproducible:
Always

Steps to Reproduce:
1.add a file to /etc/profile.d that uses the pathmunge() function
2.
3.
    

Actual Results:  the pathmunge() call fails

Expected Results:  pathmunge() should work in files in /etc/profile.d

Additional info:
Comment 1 Bill Nottingham 2004-05-24 17:39:37 EDT
Will be in 2.5.34-1, thanks!
Comment 2 Ville Skyttä 2005-12-01 06:08:19 EST
Unfortunately recent versions (at least as of FC4 and FC5test1) of the setup
package also pull in the profile.d snippets directly from /etc/bashrc where
pathmunge is not defined, so it cannot be used anyway :(
Comment 3 Phil Knirsch 2006-01-31 07:56:06 EST
OK, i've looked at it a little more closely.

Problem is that for non login shells bashrc now sources the profile.d files. The
next rawhide version will contain a fix that includes pathmunge in bashrc again
for that case.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.