Bug 123623 - xemacs is unable to start
Summary: xemacs is unable to start
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xemacs   
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-19 18:30 UTC by Airbete
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-19 19:06:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Airbete 2004-05-19 18:30:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
$ xemacs
*** Error in XEmacs initialization
(error "Must be string, vector, or font-instance" #<x-device on ":0.0"
0xac9>)
*** Backtrace
  really-early-error-handler((error "Must be string, vector, or
font-instance" #<x-device on ":0.0" 0xac9>))
  check-valid-instantiator(#<x-device on ":0.0" 0xac9> font)
  # bind (result noerror specifier-type spec)
  canonicalize-spec(#<x-device on ":0.0" 0xac9> font nil)
  # bind (rest result)
  byte-code("..." [specifier-type res2 noerror spec-list result rest
nil throw cann-spec-list t signal error "Invalid list format"
canonicalize-spec] 5)
  # (catch cann-spec-list ...)
  # bind (result noerror specifier-type spec-list)
  canonicalize-spec-list((#<x-device on ":0.0" 0xac9>) font)
  # bind (is-valid nval how-to-add tag-set locale value specifier)
  set-specifier(#<font-specifier global=((default x) .
"-*-courier-medium-r-*-*-*-120-*-*-*-*-iso8859-*") fallback=((... .
"normal") (... . "-*-courier-medium-r-*-*-*-120-*-*-*-*-iso8859-*")
(... . "-*-courier-medium-r-*-*-*-120-*-*-*-*-iso8859-*") (... .
"-*-courier-*-r-*-*-*-120-*-*-*-*-iso8859-*") (... .
"-*-*-medium-r-*-*-*-120-*-*-m-*-iso8859-*") (... .
"-*-*-medium-r-*-*-*-120-*-*-c-*-iso8859-*") ...) 0x1c9> nil
#<x-device on ":0.0" 0xac9> nil nil)
  # bind (how-to-add tag-set locale value property face)
  set-face-property(default font nil #<x-device on ":0.0" 0xac9> nil nil)
  # bind (how-to-add tag-set locale font face)
  set-face-font(default nil #<x-device on ":0.0" 0xac9>)
  # bind (new-x-font device)
  x-init-device-faces(#<x-device on ":0.0" 0xac9>)
  # bind (device)
  init-device-faces(#<x-device on ":0.0" 0xac9>)
  # (unwind-protect ...)
  # (unwind-protect ...)
  make-device(x nil)
  # bind (display)
  make-x-device(nil)
  init-x-win()
  # bind (debugger debug-on-error command-line-args-left)
  command-line()
  # (condition-case ... . ((t (byte-code "      �" ... 1))))
  # bind (error-data)
  normal-top-level()
  # (condition-case ... . error)
  # (catch top-level ...)
*** Killing XEmacs


Version-Release number of selected component (if applicable):
xemacs-21.4.15-5

How reproducible:
Always

Steps to Reproduce:
1. xemacs


Actual Results:  xemacs not launched.

Expected Results:  xemacs window should pop up

Additional info:

Comment 1 Airbete 2004-05-19 19:06:36 UTC
Ok. I'm stupid. The problem was the modification I did in
/etc/sysconfig/i18n

I revert it back to the original file and now everything is ok.
At first it wasn't obvious to me that xemacs had a font problem.

Sorry.

Comment 2 Jens Petersen 2004-05-21 06:25:49 UTC
Ok.  What was the change you made in i18n for this to happen?

I came across a similar problem recently on a box where xfs won't
run for some reason.  Perhaps xemacs should be build --without-xfs
or something to avoid this kind of information.

Comment 3 Airbete 2004-05-22 01:49:09 UTC
> What was the change you made in i18n for this to happen?

I momentarily changed the line
LANG="en_US.UTF-8"
in /etc/sysconfig/i18n for
LANG="POSIX"
cause in RH9 it solved some font problems I had.

AB.


Note You need to log in before you can comment on or make changes to this bug.