Bug 1236267 - Creating a new VM with invalid Name errors and exits the form
Summary: Creating a new VM with invalid Name errors and exits the form
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: jniederm
QA Contact: Ilanit Stein
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-27 03:55 UTC by Ulhas Surse
Modified: 2019-10-10 09:57 UTC (History)
9 users (show)

Fixed In Version: 3.6.0-4 alpha3
Doc Type: Bug Fix
Doc Text:
In the Edit Virtual Machine dialog, if an invalid name was entered, the dialog closed and a server-side error was reported. With this update, an invalid virtual machine name is handled in the standard way. The field is highlighted with a red border.
Clone Of:
Environment:
Last Closed: 2016-03-09 21:09:10 UTC
oVirt Team: Virt


Attachments (Terms of Use)
after error, the form closes and need to fill the information again from start. (19.63 KB, image/png)
2015-06-27 03:57 UTC, Ulhas Surse
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 43510 master MERGED webadmin: vm-like dialogs: name validation fixed Never

Description Ulhas Surse 2015-06-27 03:55:13 UTC
Description of problem:

  - When creating a new vm in the admin portal, if I get an error when I click Ok after configuring my VM, the form closes and I lose all my setting and have to start over. 

  - In 3.4 the configuration error was highlighted in red but did not exit the whole form.

  - Previous version allowed you to fix the name without having to start over.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager 3.5.3

How reproducible:
  Always

Steps to Reproduce:
  1) From Admin Portal/Any data center/Virtual machine/New VM
  2)Set Cluster, Quota, Template (win7), Type, Network
  3)Enter an invalid name, ie to many characters, invalid characters.
  4)Select Ok
  5)Errors with attached error and exits.

Actual results:
  VM create form closes if any wrong information is filled.

Expected results:
  The form should be available to edit the wrong information.

Additional info:

Comment 1 Ulhas Surse 2015-06-27 03:57:12 UTC
Created attachment 1043835 [details]
after error, the form closes and need to fill the information again from start.

Comment 2 Michal Skrivanek 2015-06-29 09:18:28 UTC
the validation seems to be broken (again)

Comment 3 Michal Skrivanek 2015-06-29 10:40:10 UTC
(In reply to Michal Skrivanek from comment #2)
> the validation seems to be broken (again)

in master - ??? pattern in pool dialog is broken too.

Comment 4 Ilanit Stein 2015-10-15 11:57:13 UTC
Verified on 3.6.0-15

For invalid VM name or VM pool name,
press OK highlighted in red the name field
(mentioning the problem, when pointing on it with mouse cursor),
and it didn't exit from the whole form.

Comment 7 errata-xmlrpc 2016-03-09 21:09:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.