Bug 1236269 - FSAL_GLUSTER : symlinks are not working properly if acl is enabled
Summary: FSAL_GLUSTER : symlinks are not working properly if acl is enabled
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 3.7.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jiffin
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On: 1209735
Blocks: 1214162 1215174 1235147
TreeView+ depends on / blocked
 
Reported: 2015-06-27 05:29 UTC by Jiffin
Modified: 2015-07-30 09:49 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1209735
Environment:
Last Closed: 2015-07-30 09:49:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-27 05:58:01 UTC
REVIEW: http://review.gluster.org/11438 (gfapi : symlink resolution for glfs_object) posted (#1) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)

Comment 2 Anand Avati 2015-06-27 06:50:57 UTC
REVIEW: http://review.gluster.org/11438 (gfapi : symlink resolution for glfs_object) posted (#2) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)

Comment 3 Anand Avati 2015-06-27 12:05:44 UTC
REVIEW: http://review.gluster.org/11438 (gfapi : symlink resolution for glfs_object) posted (#3) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)

Comment 4 Anand Avati 2015-06-27 12:55:42 UTC
REVIEW: http://review.gluster.org/11438 (gfapi : symlink resolution for glfs_object) posted (#4) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)

Comment 5 Anand Avati 2015-06-27 13:21:17 UTC
REVIEW: http://review.gluster.org/11438 (gfapi : symlink resolution for glfs_object) posted (#5) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)

Comment 6 Anand Avati 2015-06-27 13:39:59 UTC
REVIEW: http://review.gluster.org/11438 (gfapi : symlink resolution for glfs_object) posted (#6) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)

Comment 7 Anand Avati 2015-06-27 19:12:29 UTC
REVIEW: http://review.gluster.org/11438 (gfapi : symlink resolution for glfs_object) posted (#7) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)

Comment 8 Anand Avati 2015-06-28 07:54:14 UTC
COMMIT: http://review.gluster.org/11438 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit 49c4b7f750e94aee22d892a7171ed2ad291559e3
Author: Jiffin Tony Thottan <jthottan@redhat.com>
Date:   Thu Jun 25 15:04:18 2015 +0530

    gfapi : symlink resolution for glfs_object
    
    Generally posix expects symlink should be resolved, before performing an
    acl related operation. This patch introduces a new api glfs_h_resolve_symlink()
    which will do the same.
    
    backport of http://review.gluster.org/#/c/11410/1
    
    >Change-Id: Ieee645154455a732edfb2c28834021bab4248810
    >BUG: 1209735
    >Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    
    Change-Id: I13a83f37a9e59418fd8eb4bf2d44f828515beabf
    BUG: 1236269
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/11438
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 9 Kaushal 2015-07-30 09:49:12 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.