Bug 1236288 - Data Tiering: Files not getting promoted once demoted
Summary: Data Tiering: Files not getting promoted once demoted
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Dan Lambright
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1232625 1235269
Blocks: 1202842 1260923
TreeView+ depends on / blocked
 
Reported: 2015-06-27 10:38 UTC by Dan Lambright
Modified: 2015-10-30 17:32 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1235269
Environment:
Last Closed: 2015-07-30 09:51:46 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-27 10:39:25 UTC
REVIEW: http://review.gluster.org/11446 (tier/ctr: Ignore creation of T file and Ctr Lookup heal improvememnts) posted (#1) for review on release-3.7 by Dan Lambright (dlambrig@redhat.com)

Comment 2 Anand Avati 2015-06-27 10:41:25 UTC
REVIEW: http://review.gluster.org/11446 (tier/ctr: Ignore creation of T file and Ctr Lookup heal improvememnts) posted (#2) for review on release-3.7 by Dan Lambright (dlambrig@redhat.com)

Comment 3 Anand Avati 2015-06-28 01:11:03 UTC
COMMIT: http://review.gluster.org/11446 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 3da1a1cf339da77e47f71b245d4cac3f9dc1da38
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Sat Jun 27 06:31:53 2015 -0400

    tier/ctr: Ignore creation of T file and Ctr Lookup heal improvememnts
    
    This is a back port of 11334
    
    1) Ignore creation of T file in ctr_mknod
    2) Ignore lookup for T file in ctr_lookup
    3) Ctr_lookup:
        a. If the gfid and pgfid in empty dont record
        b. Decreased log level for multiple heal attempts
        c. Inode/File heal happens after an expiry period, which is configurable.
        d. Hardlink heal happens after an expiry period, which is configurable.
    
    > Change-Id: Id8eb5092e78beaec22d05f5283645081619e2452
    > BUG: 1235269
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/11334
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: Ia28a5cf975e41d318906f707deca447aaa35630f
    BUG: 1236288
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/11446
    Reviewed-by: Joseph Fernandes
    Tested-by: Joseph Fernandes
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 4 Kaushal 2015-07-30 09:51:46 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.