Bug 1236380 - Overcloud Horizon - unable to edit project
Summary: Overcloud Horizon - unable to edit project
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 7.0 (Kilo)
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ga
: Director
Assignee: Mike Burns
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-28 11:59 UTC by Ido Ovadia
Modified: 2016-04-18 06:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:57:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ido Ovadia 2015-06-28 11:59:54 UTC
Description of problem:
=======================
Overcloud Horizon - unable to edit project

Version-Release number of selected component (if applicable):
=============================================================
python-django-horizon-2015.1.0-10.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-15.el7ost.noarch

How reproducible:
=================
100%

Steps to Reproduce:
===================
1. Deploy overcloud
2. Log in to overcloud UI  Horizon
3. Go to Identity -> Projects
4. Select any project (e.g admin), click 'Edit Project' 

Actual results:
===============
Nothing, no edit dialog window opened

Expected results:
=================
Dialog window should open

Additional info:
================

 This bug occurs while installing by OSP-7 director,
 It doesn't happen using packstack

Comment 2 Mike Burns 2015-06-28 12:27:26 UTC
I suspect this is something we're configuring incorrectly.  We've seen a couple other horizon issues as well.  

Ido, Are there horizon logs available for this issue?  Can you collect the horizon configurations?

@mrunge -- can you review the configuration and help us figure out where the misconfiguration is?

Comment 3 Ido Ovadia 2015-06-28 14:02:16 UTC
horizon.log
===========

2015-06-28 13:59:10,105 32298 WARNING openstack_dashboard.api.cinder Cinder v2 requested but no 'volumev2' service type available in Keystone catalog.
2015-06-28 13:59:10,125 32298 WARNING horizon.exceptions Recoverable error: Invalid URL '/os-quota-sets/b55615f0cb704900ba0da22d48ced52a?usage=False': No schema supplied. Perhaps you meant http:///os-quota-sets/b55615f0cb704900ba0da22d48ced52a?usage=False?

Comment 4 Matthias Runge 2015-06-28 14:16:26 UTC
Mike,

Horizon relies on volumev2 endpoint. It is called, when collecting quota information. I know, there has been an issue in director, where volumev2 endpoint was not created. I suspect, this setup was set up by a version not including the fix.
This should be a duplicate of bug 1233956

Comment 5 Ido Ovadia 2015-06-29 12:52:28 UTC
Verified
========
os-cloud-config-0.2.8-4.el7ost.noarch
python-django-horizon-2015.1.0-10.el7ost.noarch

Comment 6 Scott Lewis 2015-06-30 14:14:56 UTC
adding pm_ack+ for TestOnly bug that's already verified

Comment 8 errata-xmlrpc 2015-08-05 13:57:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.