Bug 1236399 - missing few neutron parameters on CLI
Summary: missing few neutron parameters on CLI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin
Version: Director
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Director
Assignee: Dougal Matthews
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On: 1240631
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-28 15:24 UTC by Ofer Blaut
Modified: 2015-08-05 13:57 UTC (History)
15 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-30.el7ost
Doc Type: Bug Fix
Doc Text:
The CLI had no method of customizing certain Neutron parameters. This fix adds news arguments to the deploy command. The user provides these arguments with "Openstack overcloud deploy" command to configure these parameters.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:57:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 238712 None None None Never
Gerrithub.io 238980 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ofer Blaut 2015-06-28 15:24:52 UTC
Description of problem:

Following bug https://bugzilla.redhat.com/show_bug.cgi?id=1233962

1. ML2_MECHANISM_DRIVER
2. NEUTRON_L3_EXT_BRIDGE = Provider or br-ex
3. Other service like LBaaS V1/V2  FWaaS 
4. ML2_TUNNEL_ID_RANGES=10:10000
5. ML2_VNI_RANGES=10:100



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Dougal Matthews 2015-06-29 15:00:08 UTC
Do you have an example of how to do this in instack or which Heat parameters these relate to?

Comment 3 Ofer Blaut 2015-06-30 16:55:15 UTC
I  think you should talk to Dan Sneddon

There are lots of parameters under - /usr/share/openstack-tripleo-heat-templates/overcloud-without-mergepy.yaml

Comment 4 Mike Burns 2015-07-01 11:33:54 UTC
moving needinfo to Dan per comment 3.

Comment 7 Hugh Brock 2015-07-02 11:02:50 UTC
Question: Are items 1, 4, and 5 things that can be configured via the overcloud Neutron command line, or are they real overcloud config parameters? What about item 2?

Comment 8 Giulio Fidente 2015-07-02 11:15:52 UTC
4 and 5 do not have params, but can be customized in the hieradata:

https://github.com/openstack/tripleo-heat-templates/blob/master/puppet/hieradata/common.yaml#L16-L19

1 can be customized using param at:

https://github.com/openstack/tripleo-heat-templates/blob/master/overcloud-without-mergepy.yaml#L147

Comment 9 Mike Orazi 2015-07-02 13:08:14 UTC
@jayg

Can you help compare and contrast what is configurable via quickstack?

Comment 10 Jason Guiditta 2015-07-02 13:45:08 UTC
(In reply to Mike Orazi from comment #9)
> @jayg
> 
> Can you help compare and contrast what is configurable via quickstack?

Mike, yes we expose 1, 4, and 5 currently in quickstack.  Some vendors may have a mech driver they wish to use becsides ovs (cisco, for instance).  Let me know if more detail is needed on this.

Comment 12 Dougal Matthews 2015-07-06 14:39:38 UTC
Posted a change to fix 1. https://review.gerrithub.io/#/c/238712/

It sounds like 2 & 3 should be in their own non-blocking BZ and 4 & 5 need additional template parameters to be added and exposed.

Comment 13 Dougal Matthews 2015-07-06 14:40:13 UTC
Posted a change to fix 1. https://review.gerrithub.io/#/c/238712/

It sounds like 2 & 3 should be in their own non-blocking BZ and 4 & 5 need additional template parameters to be added and exposed.

Comment 15 Dougal Matthews 2015-07-07 12:01:29 UTC
Two bugs

For 4 & 5 - this should be marked as ablocker.
https://bugzilla.redhat.com/show_bug.cgi?id=1240631

For 2 & 3 - this is lower priority
https://bugzilla.redhat.com/show_bug.cgi?id=1240635

Comment 18 Ana Krivokapic 2015-07-10 11:24:35 UTC
We still need https://review.gerrithub.io/#/c/238980/ to land before we can call this bug done.

Comment 20 Eran Kuris 2015-07-16 09:29:06 UTC
1. ML2_MECHANISM_DRIVER
4. ML2_TUNNEL_ID_RANGES=10:10000
5. ML2_VNI_RANGES=10:100

verified and fixed 
RHEL-OSP director puddle 7.0 RC - 2015-07-13.1
[stack@instack ~]$ sudo rpm -qa |grep python-rdomanager-oscplugin
python-rdomanager-oscplugin-0.0.8-32.el7ost.noarch

validate deployment with the command : 
openstack  overcloud deploy --plan-uuid e005128b-bdd3-44b1-8ff0-752e75c6dc0e  --neutron-tunnel-id-ranges 33:3333  --neutron-vni-ranges 44:4444 --neutron-mechanism-drivers openvswitch


checked after deploy in the controller : 
[heat-admin@overcloud-controller-0 ~]$ sudo vi /etc/neutron/plugin.ini
[heat-admin@overcloud-controller-0 ~]$ sudo vi /etc/neutron/plugins/ml2/ml2_conf.ini



2. NEUTRON_L3_EXT_BRIDGE = Provider or br-ex
3. Other service like LBaaS V1/V2  FWaaS 
the problem for those parameter still exist : 
https://bugzilla.redhat.com/show_bug.cgi?id=1240635

Comment 22 errata-xmlrpc 2015-08-05 13:57:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.