Bug 1236423 - [abrt] BUG: unable to handle kernel NULL pointer dereference at 0000000000000010 [radeon]
Summary: [abrt] BUG: unable to handle kernel NULL pointer dereference at 0000000000000...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:184a727d80efc463c1fac3d07f9...
: 1240463 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-28 22:20 UTC by Andreas Tunek
Modified: 2015-08-30 15:25 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-04 19:05:17 UTC
Type: ---


Attachments (Terms of Use)
File: dmesg (124.34 KB, text/plain)
2015-06-28 22:20 UTC, Andreas Tunek
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 91253 None None None Never

Description Andreas Tunek 2015-06-28 22:20:44 UTC
Description of problem:
tried to boot computer.

Additional info:
reporter:       libreport-2.6.0
BUG: unable to handle kernel NULL pointer dereference at 0000000000000010
IP: [<ffffffffa0222ab7>] radeon_audio_detect+0x117/0x160 [radeon]
PGD 8bf4a067 PUD 8bf4b067 PMD 0 
Oops: 0002 [#1] SMP 
Modules linked in: radeon 8021q garp stp llc mrp i2c_algo_bit drm_kms_helper ttm drm tg3 sdhci_pci sdhci mmc_core ptp pps_core
CPU: 2 PID: 266 Comm: plymouthd Not tainted 4.0.5-300.fc22.x86_64 #1
Hardware name: Apple Inc. iMac15,1/Mac-42FD25EABCABB274, BIOS IM151.88Z.0207.B01.1411201235 11/20/2014
task: ffff88003f8209f0 ti: ffff88003f848000 task.ti: ffff88003f848000
RIP: 0010:[<ffffffffa0222ab7>]  [<ffffffffa0222ab7>] radeon_audio_detect+0x117/0x160 [radeon]
RSP: 0018:ffff88003f84bbc8  EFLAGS: 00010246
RAX: ffff880262772504 RBX: ffff8802609ba000 RCX: 0000000000000006
RDX: 0000000000000000 RSI: 0000000000000292 RDI: 0000000000000292
RBP: ffff88003f84bbe8 R08: ffff8802611a0000 R09: 0000000000000100
R10: 0000000000000000 R11: 00000000000000de R12: 0000000000000000
R13: ffff880262770000 R14: ffff88003f837c00 R15: ffff880262770000
FS:  00007f98b8210700(0000) GS:ffff88026f280000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 0000000000000010 CR3: 000000008bf49000 CR4: 00000000001407e0
Stack:
 ffff8802609ba000 0000000000000001 ffff8802612105c0 ffff88003f837e00
 ffff88003f84bc28 ffffffffa016145b ffffffff81fd6f80 ffff8802609ba050
 ffff8802609ba000 0000000000000001 ffff88008be36800 0000000000000001
Call Trace:
 [<ffffffffa016145b>] radeon_dp_detect+0x22b/0x2c0 [radeon]
 [<ffffffffa011bcc8>] drm_helper_probe_single_connector_modes_merge_bits+0x248/0x500 [drm_kms_helper]
 [<ffffffff8132ce0b>] ? cred_has_capability+0x6b/0x130
 [<ffffffff81483876>] ? tty_ldisc_deref+0x16/0x20
 [<ffffffffa011bf93>] drm_helper_probe_single_connector_modes+0x13/0x20 [drm_kms_helper]
 [<ffffffffa00a28c0>] drm_mode_getconnector+0x340/0x3a0 [drm]
 [<ffffffff8132cff2>] ? selinux_capable+0x32/0x40
 [<ffffffffa0093a5b>] drm_ioctl+0x1db/0x640 [drm]
 [<ffffffffa00a2580>] ? drm_mode_getcrtc+0xf0/0xf0 [drm]
 [<ffffffffa013704c>] radeon_drm_ioctl+0x4c/0x80 [radeon]
 [<ffffffff81232036>] do_vfs_ioctl+0x2c6/0x4d0
 [<ffffffff812322c1>] SyS_ioctl+0x81/0xa0
 [<ffffffff81789d48>] ? int_check_syscall_exit_work+0x34/0x3d
 [<ffffffff81789b09>] system_call_fastpath+0x12/0x17
Code: b8 02 00 00 4d 8b a6 00 01 00 00 48 8b 82 68 01 00 00 48 85 c0 74 47 48 8b 48 08 31 c0 48 85 c9 74 09 48 8b 02 48 8b 78 28 ff d1 <49> 89 44 24 10 49 8b 85 e0 25 00 00 48 8b 40 10 48 85 c0 0f 84 
RIP  [<ffffffffa0222ab7>] radeon_audio_detect+0x117/0x160 [radeon]
 RSP <ffff88003f84bbc8>
CR2: 0000000000000010

Comment 1 Andreas Tunek 2015-06-28 22:20:49 UTC
Created attachment 1044124 [details]
File: dmesg

Comment 2 Andreas Tunek 2015-06-28 22:21:29 UTC
4.0.4 works without a problem.

Comment 3 Andreas Tunek 2015-06-29 08:29:13 UTC
Can't boot 4.0.6 either.

Comment 4 Andreas Tunek 2015-07-01 19:01:06 UTC
Also happens on 4.0.7 in updates-testing.

Comment 5 Kamil Páral 2015-07-02 16:30:46 UTC
I can't reproduce this on Radeon R9 270 with a DisplayPort (nor DVI) monitor. It probably affects only certain cards (or maybe just Macs?).

I'm not a maintainer of this component, but if you want to increase your chances of seeing this fixed, I suggest to report this to the upstream freedesktop bugzilla. See bug 1224579 (similar, but probably unrelated) for instructions how to do that.

Comment 7 Andreas Tunek 2015-07-07 08:45:53 UTC
Maybe it would be better if I tested the rawhide kernel? Can you do that in F22_

Comment 8 Kamil Páral 2015-07-07 08:53:07 UTC
Yes, you can see them here:
http://koji.fedoraproject.org/koji/packageinfo?packageID=8
You should be able to install F23 kernel on F22 just fine. (Some of them might have debugging options enabled, and be therefore considerably slower.)

Comment 9 Andreas Tunek 2015-07-07 14:28:43 UTC
Tested rawhide kernel, bug report is here: https://bugzilla.redhat.com/show_bug.cgi?id=1240566

Comment 10 Andreas Tunek 2015-07-19 07:27:07 UTC
So now I should test F23 kernels as well?

Comment 11 Kamil Páral 2015-07-20 07:29:44 UTC
I see that you received feedback in the upstream freedesktop bug, but you haven't replied since then. If you want to see this fixed, your best chance is to study how to build your own kernel and then bisect the versions until you find the wrong commit. It requires quite some technical skills. If you don't feel up to it, you'll need to wait until someone else is able to reproduce the issue on their hardware and will do the bisecting. Or you can try to find someone technical in your surroundings, lend him your hardware and ask him/her to do it for you.

Comment 12 Laura Abbott 2015-07-20 19:12:34 UTC
If you need help with bisect, you can experiment with some scripts I wrote for making bisection on fedora easier https://pagure.io/fedbisect

Comment 13 Andreas Tunek 2015-07-21 19:34:04 UTC
(In reply to Kamil Páral from comment #11)
> I see that you received feedback in the upstream freedesktop bug, but you
> haven't replied since then. If you want to see this fixed, your best chance
> is to study how to build your own kernel and then bisect the versions until
> you find the wrong commit. It requires quite some technical skills. If you
> don't feel up to it, you'll need to wait until someone else is able to
> reproduce the issue on their hardware and will do the bisecting. Or you can
> try to find someone technical in your surroundings, lend him your hardware
> and ask him/her to do it for you.

I would like to see if the patch in https://bugzilla.redhat.com/show_bug.cgi?id=1224579 works, but that does not seem to be applied upstream.

Comment 14 Andreas Tunek 2015-07-24 20:10:30 UTC
4.1.2-200.fc22  does not work either.

Comment 15 Andreas Tunek 2015-08-04 19:05:17 UTC
Fixed in 4.2 rc5

Comment 16 Nick Urbanik 2015-08-30 15:25:42 UTC
*** Bug 1240463 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.