Bug 1236488 - Review Request: indistarter - GUI for Indi Server
Summary: Review Request: indistarter - GUI for Indi Server
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christian Dersch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: Astronomy-SIG
TreeView+ depends on / blocked
 
Reported: 2015-06-29 08:24 UTC by Mattia Verga
Modified: 2015-12-20 06:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-20 06:53:56 UTC
lupinix.fedora: fedora-review+


Attachments (Terms of Use)
Output of licensecheck (2.94 KB, text/plain)
2015-12-09 17:51 UTC, Christian Dersch
no flags Details

Description Mattia Verga 2015-06-29 08:24:25 UTC
Spec URL: http://coolbits.it/files/indistarter.spec
SRPM URL: http://coolbits.it/files/indistarter-0.1.0.20150623svn-1.fc21.src.rpm

Description: Indistarter is a user interface to run a INDI server.
You can configure different profile for your astronomical equipment.
The INDI server can be launched locally or remotely on another computer.
In this last case a ssh tunnel is established to allow local client connection.

Fedora Account System Username: mattia

Comment 1 Sören Möller 2015-07-14 20:37:24 UTC
I wanted to do an informal review of this package, but the download from fedora-review fails:
$ fedora-review -b 1236488
INFO: Processing bugzilla bug: 1236488
INFO: Getting .spec and .srpm Urls from : 1236488
INFO:   --> SRPM url: http://coolbits.it/files/indistarter-0.1.0.20150623svn-1.fc21.src.rpm
INFO:   --> Spec url: http://coolbits.it/files/indistarter.spec
INFO: Using review directory: /home/scren/review/1236488-indistarter
INFO: Downloading .spec and .srpm files
ERROR: 'Error 403 downloading http://coolbits.it/files/indistarter-0.1.0.20150623svn-1.fc21.src.rpm' (logs in /home/scren/.cache/fedora-review.log)

As I very much would prefer to use the automation of fedora-review, it would be quite helpful if this problem could be solved.

Comment 2 Mattia Verga 2015-07-15 15:15:29 UTC
I don't know why fedora-review gives an Error 403, if you download the src.rpm file from a browser the link works.

You can download it and then use 'fedora-review --rpm-spec --name indistarter'.

Thanks.

Comment 3 Sören Möller 2015-07-15 21:18:55 UTC
Thanks for the explanation, I now have downloaded it.

My first build with fedora-review failed, as 
appstream-util 
was not found, but adding
BuildRequires:	libappstream-glib
to the .spec-file solved that problem, and I was able to build, so you might want to add that to the .spec too.

Comment 4 Sören Möller 2015-07-15 22:01:03 UTC
After running fedora-review one of the first problems encountered was the following warning:

[ ]: Package must own all directories that it creates.
     Note: Directories without known owners: /usr, /usr/bin,
     /usr/share/pixmaps, /usr/share/applications, /usr/share,
     /usr/share/appdata, /usr/share/doc, /usr/share/icons

I removed this warning by changing

%files
%doc %{_docdir}/indistarter
%{_bindir}/*
%{_datadir}/applications/*.desktop
%{_datadir}/appdata/*.appdata.xml
%{_datadir}/icons/*
%{_datadir}/pixmaps/*

from your .spec file to

%files
%doc %{_docdir}/indistarter
%{_bindir}/%{name}
%{_datarootdir}/applications/%{name}.desktop
%{_datarootdir}/appdata/%{name}.appdata.xml
%{_datarootdir}/icons/hicolor/48x48/apps/%{name}.png
%{_datarootdir}/pixmaps/%{name}.png

which resolves this warning. I think this change or something similar is necessary, as your .spec file seems to indicate that the package wants to own all of (for instance) %{_bindir} and not only the file it provides into the pre-existing directory.

Comment 5 Mattia Verga 2015-07-31 15:10:46 UTC
Thanks Sören, I've fixed issues you pointed out, plus I fixed version number that was wrong.
These are the new files:
Spec URL: http://coolbits.it/files/indistarter.spec
SRPM URL: http://coolbits.it/files/indistarter-0.1.0-2.20150623svn.fc21.src.rpm

I'm aware that there are more issues and I'm working on it:
- debuginfo rpm is empty
- rpmlint says the appdata file is wrong, but running appdata-validate shows no issues...

Comment 6 Christian Dersch 2015-11-30 15:38:09 UTC
Looks interesting to me :) Is this still up to date? If yes I'll review it.

Greetings,
Christian

Comment 7 Mattia Verga 2015-11-30 19:50:34 UTC
Yes, there was no other change in project code since 2015/06/23, so it's still up to date.

Comment 8 Christian Dersch 2015-11-30 20:45:06 UTC
First comment: You have to add desktop-file-utils to BuildRequires.

Did you solve the debuginfo problem?

Comment 9 Mattia Verga 2015-12-01 09:08:08 UTC
(In reply to Christian Dersch from comment #8)
> First comment: You have to add desktop-file-utils to BuildRequires.
> 
Thanks, I gave another look at .spec file and I found a couple of other things to tweak. Please give me a week or so to create a new version.

> Did you solve the debuginfo problem?
>
No, I found other programs in Fedora created with fpc and lazarus with debuginfo disabled, but there are few other that can generate valid debuginfo... I started to look at that, but then I stopped. I will retry to found the cause, but I think I will need some help and may take some more time.

Comment 10 Mattia Verga 2015-12-03 08:55:02 UTC
Spec URL: http://www.coolbits.it/fedora/indistarter.spec
SRPM URL: http://www.coolbits.it/fedora/indistarter-0.2.0.20151203svn-1.fc23.src.rpm

Yesterday the developer released an update version.
I made a new .src.rpm and .spec that fixes a lot of things:
- Added desktop-file-utils in BuildRequires
- Removed unneeded ldconfig calls (no libraries are installed)
- Added patch to avoid debuginfo stripping (fixes void debuginfo package - this will not reported upstream, because developer wants to strip debuginfo to optimize his package builds)
- Added patch to fix appdata validation (reported upstream - see in .spec file)

Note that rpmlint gives an error because I explicitly require libindi. Libindi does not merely contain libraries, but also carries indiserver executable. I can avoid requiring libindi because indistarter can "function" without it, but it makes no sense to me having indistarter installed without indiserver... we can ask on devel mailing list if in doubt.

Comment 11 Christian Dersch 2015-12-03 11:34:09 UTC
Well for me it makes sense without dependency on libindi. You can control remote indi servers with indistarter too.

Comment 12 Christian Dersch 2015-12-03 20:15:41 UTC
Link to src.rpm is broken :(

Comment 13 Mattia Verga 2015-12-04 07:26:24 UTC
Spec URL: http://www.coolbits.it/fedora/indistarter.spec
SRPM URL: http://www.coolbits.it/fedora/indistarter-0.2.0-2.20151203svn.fc23.src.rpm

Sorry, I messed up release number.... ;-)

I didn't think to control remote indi servers, so I removed libindi dependency in the latest version.

Comment 14 Upstream Release Monitoring 2015-12-06 14:23:17 UTC
lupinix's scratch build of indistarter-0.2.0-2.20151203svn.fc23.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=12086396

Comment 15 Christian Dersch 2015-12-09 15:33:20 UTC
Looks like there is a problem with rawhide, everything works fine with F23 and I got the same issue with two other review. I'll try to figure out the reason of failure.


Finish: chroot init
INFO: installing package(s): /home/review/indistarter/results/indistarter-0.2.0-2.20151203svn.fc24.x86_64.rpm /home/review/indistarter/results/indistarter-debuginfo-0.2.0-2.20151203svn.fc24.x86_64.rpm /home/review/indistarter/results/indistarter-debuginfo-0.2.0-2.20151203svn.fc24.x86_64.rpm
ERROR: Command failed. See logs for output.
 # /usr/bin/dnf --installroot /var/lib/mock/fedora-rawhide-x86_64/root/ --releasever 24 --setopt=deltarpm=false install /home/review/indistarter/results/indistarter-0.2.0-2.20151203svn.fc24.x86_64.rpm /home/review/indistarter/results/indistarter-debuginfo-0.2.0-2.20151203svn.fc24.x86_64.rpm /home/review/indistarter/results/indistarter-debuginfo-0.2.0-2.20151203svn.fc24.x86_64.rpm --setopt=tsflags=nocontexts
 None
None
INFO: Install command returned error code 30

Comment 16 Mattia Verga 2015-12-09 16:32:45 UTC
(In reply to Christian Dersch from comment #15)
> Looks like there is a problem with rawhide, everything works fine with F23
> and I got the same issue with two other review. I'll try to figure out the
> reason of failure.
> 

Yes, it's a known bug of fedora-review. There was a discussion on the devel mailing list a week ago about that. See bug #1264803 they have fixed it upstream but not released a new version yet...

Comment 17 Christian Dersch 2015-12-09 16:39:01 UTC
Thanks for info :) As the issue is known and package itself builds fine @rawhide it is ok to use F23 for review => Will follow soon :)

Comment 18 Christian Dersch 2015-12-09 17:49:01 UTC
Not yet approved, but single issue is License tag. Also: Please query upstream to include license text.


Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[-]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.

====> Please add this when upstream added the license texts (hopefully)


[!]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "GPL (v3 or later)", "Unknown or generated", "LGPL (v2 or
     later) (with incorrect FSF address)". 45 files have unknown license.
     Detailed output of licensecheck in
     /home/review/indistarter/licensecheck.txt

=====> License tag should be "GPLv3 and GPLv3+ and LGPLv2+" if I interpret situation correctly
  Upstream says "GPL-3" in copyright (does he mean GPLv3 or GPLv3+ ?), copyright headers say GPLv3+ (and LGPLv2+ in some cases) 
  Check https://fedoraproject.org/wiki/Packaging:LicensingGuidelines?rd=Packaging/LicensingGuidelines#Multiple_Licensing_Scenarios

  Also please add a license breakdown to spec as a comment, if not clear: Query upstream

[-]: License file installed when any subpackage combination is installed.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: gtk-update-icon-cache is invoked in %postun and %posttrans if package
     contains icons.
     Note: icons in indistarter
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 10240 bytes in 2 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package contains desktop file if it is a GUI application.
[x]: Package installs a %{name}.desktop using desktop-file-install or
     desktop-file-validate if there is such a file.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: Uses parallel make %{?_smp_mflags} macro.

====> Doesn't use parallel make as comment in spec shows us

[!]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.

====> Please query upstream for this

[x]: Final provides and requires are sane (see attachments).
[-]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in
     indistarter-debuginfo
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[x]: SourceX tarball generation or download is documented.
     Note: Package contains tarball without URL, check comments
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
===> See http://koji.fedoraproject.org/koji/taskinfo?taskID=12086396

[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on debuginfo package(s).
     Note: No rpmlint messages.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.


Rpmlint
-------
Checking: indistarter-0.2.0-2.20151203svn.fc23.x86_64.rpm
          indistarter-debuginfo-0.2.0-2.20151203svn.fc23.x86_64.rpm
          indistarter-0.2.0-2.20151203svn.fc23.src.rpm
indistarter.x86_64: W: no-manual-page-for-binary indistarter
indistarter.src:41: W: configure-without-libdir-spec
indistarter.src: W: invalid-url Source0: indistarter.tar.xz
3 packages and 0 specfiles checked; 0 errors, 3 warnings.




Rpmlint (debuginfo)
-------------------
Checking: indistarter-debuginfo-0.2.0-2.20151203svn.fc23.x86_64.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.





Rpmlint (installed packages)
----------------------------
sh: /usr/bin/python: No such file or directory
indistarter.x86_64: W: no-manual-page-for-binary indistarter
2 packages and 0 specfiles checked; 0 errors, 1 warnings.



Requires
--------
indistarter (rpmlib, GLIBC filtered):
    /bin/sh
    libX11.so.6()(64bit)
    libatk-1.0.so.0()(64bit)
    libc.so.6()(64bit)
    libcairo.so.2()(64bit)
    libdl.so.2()(64bit)
    libgdk-x11-2.0.so.0()(64bit)
    libgdk_pixbuf-2.0.so.0()(64bit)
    libglib-2.0.so.0()(64bit)
    libgmodule-2.0.so.0()(64bit)
    libgobject-2.0.so.0()(64bit)
    libgthread-2.0.so.0()(64bit)
    libgtk-x11-2.0.so.0()(64bit)
    libpango-1.0.so.0()(64bit)
    libpthread.so.0()(64bit)

indistarter-debuginfo (rpmlib, GLIBC filtered):



Provides
--------
indistarter:
    appdata()
    appdata(indistarter.appdata.xml)
    application()
    application(indistarter.desktop)
    indistarter
    indistarter(x86-64)

indistarter-debuginfo:
    indistarter-debuginfo
    indistarter-debuginfo(x86-64)



Generated by fedora-review 0.6.0 (3c5c9d7) last change: 2015-05-20
Command line :/usr/bin/fedora-review -v -m fedora-23-x86_64 --rpm-spec -n indistarter-0.2.0-2.20151203svn.fc23.src.rpm
Buildroot used: fedora-23-x86_64
Active plugins: Generic, Shell-api
Disabled plugins: Java, C/C++, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP, Ruby
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

Comment 19 Christian Dersch 2015-12-09 17:51:41 UTC
Created attachment 1104064 [details]
Output of licensecheck

Comment 20 Mattia Verga 2015-12-09 19:41:05 UTC
Spec URL: http://www.coolbits.it/fedora/indistarter.spec
SRPM URL: http://www.coolbits.it/fedora/indistarter-0.2.0-2.20151203svn.fc23.src.rpm

As stated in 
https://fedoraproject.org/wiki/Licensing:FAQ?rd=Licensing/FAQ#How_should_I_handle_multiple_licensing_situations.3F
Indistarter is a single executable compiled with multiple sources with different licenses. Between LGPLv2+ and GPLv3+ the stricter is GPLv3+, which is in the sources header.

I've corrected the License tag to GPLv3+, added license to the package and opened a ticket upstream (see .spec file comment).

Comment 21 Christian Dersch 2015-12-09 19:52:22 UTC
OK, License tag should be fine now :) But please remove the GPL copy you added now, in Guidelines we have the should item "Package does not include license text files separate from upstream." (see review). Just remember to add the %license in future releases when upstream added a copy of GPLv3.

As I think you can fix this on SCM import and is only a SHOULD, not a MUST: Approved!

Btw: I'll add this to our Astronomy Spin (to be released with Fedora 24).

Comment 22 Christian Dersch 2015-12-09 19:54:46 UTC
And of couse: Thank you for packaging indistarter! Looks very useful to me for our remote controlled devices :)

Comment 23 Mattia Verga 2015-12-09 20:20:04 UTC
(In reply to Christian Dersch from comment #21)
> OK, License tag should be fine now :) But please remove the GPL copy you
> added now, in Guidelines we have the should item "Package does not include
> license text files separate from upstream." (see review). Just remember to
> add the %license in future releases when upstream added a copy of GPLv3.
> 
Ah, ok, sorry. I misread the guidelines at
https://fedoraproject.org/wiki/Packaging:LicensingGuidelines?rd=Packaging/LicensingGuidelines#License_Text
where they say that the packager should include the license text if missing ;-) I will remove before importing in SCM.

Thanks.
I plan to also package the other programs from Patrick Chevalley: EqmodGui, CCDciel and Virtual Planet Atlas. I'm waiting for a response from Patrick for few issues. I will add them to the tracker of Astronomy SIG when ready. (for the moment you can find some test builds on my copr mattia/Astronomy if you want to try)

Comment 24 Fedora Update System 2015-12-11 16:48:13 UTC
indistarter-0.2.0-4.20151211svn.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1b6b52d7e8

Comment 25 Fedora Update System 2015-12-12 03:22:46 UTC
indistarter-0.2.0-4.20151211svn.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update indistarter'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1b6b52d7e8

Comment 26 Fedora Update System 2015-12-20 06:53:53 UTC
indistarter-0.2.0-4.20151211svn.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.