Bug 1236507 - error not correct when use console cmd to open a guest which guest console type is not pty
Summary: error not correct when use console cmd to open a guest which guest console ty...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.2
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-29 09:30 UTC by Luyao Huang
Modified: 2015-11-19 06:42 UTC (History)
6 users (show)

Fixed In Version: libvirt-1.2.17-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 06:42:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description Luyao Huang 2015-06-29 09:30:49 UTC
Description of problem:
error not correct when use console cmd to open a guest which guest console type is not pty

Version-Release number of selected component (if applicable):
libvirt-1.2.16-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.prepare a running guest which console type is not pty

# virsh dumpxml test4
    <serial type='file'>
      <source path='/var/lib/libvirt/qemu/aaa'/>
      <target port='0'/>
      <alias name='serial0'/>
    </serial>
    <console type='file'>
      <source path='/var/lib/libvirt/qemu/aaa'/>
      <target type='serial' port='0'/>
      <alias name='serial0'/>
    </console>

2. use console command:
# virsh console test4
Connected to domain test4
Escape character is ^]
error: internal error: character device <null> is not using a PTY

3.
Actual results:
in step 2 libvirt output a <null> but it should be a character device name

Expected results:

# virsh console test4
Connected to domain test4
Escape character is ^]
error: internal error: character device console0 is not using a PTY


Additional info:

This will be fixed by commit:

commit 898e76f0aac9a9cb200006e4dc1b598934737fb8
Author: Luyao Huang <lhuang@redhat.com>
Date:   Mon Jun 15 21:58:36 2015 +0800

    Improve some errors for openconsole/channel
    
    Functions like virDomainOpenConsole() and virDomainOpenChannel() accept
    NULL as a dev_name parameter.  Try using alias for the error message if
    dev_name is not specified.
    
    Before:
      error: internal error: character device <null> is not using a PTY
    
    After:
      error: internal error: character device serial0 is not using a PTY
    
    Signed-off-by: Luyao Huang <lhuang@redhat.com>

Comment 1 Peter Krempa 2015-06-29 09:36:24 UTC
git desc:

v1.2.16-281-g898e76f

Comment 3 Shanzhi Yu 2015-07-13 09:18:49 UTC
Verify this bug with libvirt-1.2.17-2.el7.x86_64


1. Prepare a running guest with below configurations
# virsh list 
 Id    Name                           State
----------------------------------------------------
 21    r7                             running


# virsh dumpxml r7
...

  <serial type='file'>
      <source path='/var/lib/libvirt/qemu/aaa'/>
      <target port='0'/>
      <alias name='serial0'/>
    </serial>
    <console type='file'>
      <source path='/var/lib/libvirt/qemu/aaa'/>
      <target type='serial' port='0'/>
      <alias name='serial0'/>
    </console>
...

2. Connect to guest console 
# virsh console r7 
Connected to domain r7
Escape character is ^]
error: internal error: character device console0 is not using a PTY


The error is expected, so verify this bug.

Comment 5 errata-xmlrpc 2015-11-19 06:42:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.