Bug 123651 - boot cd keyboard not working emachines laptop
boot cd keyboard not working emachines laptop
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: 125564
  Show dependency treegraph
 
Reported: 2004-05-19 16:35 EDT by Seth Reinoso
Modified: 2015-01-04 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 02:13:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Reinoso 2004-05-19 16:35:28 EDT
Description of problem:
When installing from CD keyboard stops working at test phase.

Version-Release number of selected component (if applicable):
Fedora Core 2 x86_64

How reproducible:
Very

Steps to Reproduce:
1. Boot machine with cd 
2. Press enter at boot screen

Actual results:
Keyboard fails to work at test phase 

Expected results:
pass test phase and install continues

Additional info:
E-Machines M6807
Comment 1 Marty Shannon 2004-05-22 15:42:54 EDT
This is also the case for the M6508 from eMachines.  Actually, it has
been suggested on the mailing lists of other distributions that the
*only* solution to this is to force USB (UHCI) into the kernel
statically, not as a module.
Comment 2 Kedar Patankar 2004-05-23 16:35:42 EDT
Also happens in case of i386 install on emachines 6805 (athlon64)
laptop. Interestingly even mandrake 10 (i386) had the same problem.
However FC2 for x86_64 seems to be OK.
Comment 3 Marty Shannon 2004-05-23 17:14:21 EDT
No, the FC2 x86_64 DVD image *does* have this problem on the eMachines
M6805 (sorry, I got the model number wrong above).  I have not tried
the i386 image at all.
Comment 4 Marty Shannon 2004-07-14 11:35:30 EDT
This is still broken in FC3T1.  How can I encourage something to be
done to fix this?
Comment 5 Marty Shannon 2004-07-31 11:44:11 EDT
The latest Gentoo CD (2004.2) boots fine on this machine (albeit with
a special kernel).  There really are only a few things that need to be
done to build a RH kernel that can handle the M650X series.  Will it
happen with FC3 at all?
Comment 6 Marty Shannon 2004-08-19 12:12:32 EDT
(See also bugzilla #120832.)  This issue is solved by upgrading the
BIOS firmware.  Details in 120832.
Comment 7 JC 2004-10-21 14:06:08 EDT
I have an emachines M6805. I had the same problem. I fixed it by
getting  a wireless keyboard that works through USB. The installer
will automatically recognize the USB keyboard.
Comment 8 Dave Jones 2005-04-16 02:13:17 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.