Bug 123652 - /usr/lib/liblammpi++ missing from lam
/usr/lib/liblammpi++ missing from lam
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: lam (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 16:39 EDT by Michael J. Carter
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: 7.0.6-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 11:27:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Carter 2004-05-19 16:39:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040211 Firefox/0.8

Description of problem:
The library /usr/lib/liblammpi++ is missing from the lam-6.5.9-1 rpm.
The file appears to be a requirement for the /usr/bin/hcp program.
This library was included w/ the lam rpm shipped with Red Hat 7.X.

carter@rhel3ws-test1$ rpm -q lam
lam-6.5.9-1

carter@rhel3ws-test1$ rpm -ql lam | grep /usr/lib
/usr/lib/liblam.a
/usr/lib/liblam.la
/usr/lib/liblamf77mpi.a
/usr/lib/liblamf77mpi.la
/usr/lib/libmpi.a
/usr/lib/libmpi.la
/usr/lib/libpmpi.a
/usr/lib/libpmpi.la

carter@rhel3ws-test1$ /usr/bin/hcp
WARNING: /usr/bin/hcc expected to find liblammpi++.* in /usr/lib
WARNING: MPI C++ API support will be disabled
hcc: No such file or directory

I don't understand why 'hcc' is not found either:

carter@rhel3ws-test1$ which hcc
/usr/bin/hcc






Version-Release number of selected component (if applicable):
/usr/lib/liblammpi++ missing from lam 

How reproducible:
Always

Steps to Reproduce:
1. run '/usr/bin/hcp'
2.
3.
    

Actual Results:  WARNING: /usr/bin/hcc expected to find liblammpi++.*
in /usr/lib
WARNING: MPI C++ API support will be disabled
hcc: No such file or directory

Expected Results:  No errors or warnings.

Additional info:
Comment 1 Lon Hohberger 2004-06-09 17:05:28 EDT
Probably because of the spec file unsetting targets/install paths.

Looking deeper...
Comment 2 Lon Hohberger 2004-06-10 13:30:04 EDT
I built a new lam package into rawhide.

lam-7.0.6-2

Should be in tomorrow.
Comment 4 Lon Hohberger 2004-06-10 13:31:38 EDT
Reopening; accidentally closed it.
Comment 5 Lon Hohberger 2004-06-23 11:27:17 EDT
This should be fixed in:

http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/lam-7.0.6-3.src.rpm

In the 6.5.8/6.5.9 tree, this feature apparently was disabled
intentionally because of a problems with varargs (va_*) functions and
the C++ interface.
Comment 6 Michael J. Carter 2004-07-02 18:13:45 EDT
I built this source RPM on RHEL3WS, installed it, and now I get:

carter@willamette$ /usr/bin/hcp
/usr/lib/gcc-lib/i386-redhat-linux/3.2.3/../../../crt1.o(.text+0x18):
In function `_start':
: undefined reference to `main'
collect2: ld returned 1 exit status
/usr/bin/hcp: No such file or directory

carter@willamette$ rpm -qf /usr/lib/crt1.o
glibc-devel-2.3.2-95.6

Note You need to log in before you can comment on or make changes to this bug.