Bug 1236532 - Cannot get content view filter description using hammer info
Summary: Cannot get content view filter description using hammer info
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.1.0
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Og Maciel
URL: http://projects.theforeman.org/issues...
Whiteboard: FAILEDQA in Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-29 11:25 UTC by Oleksandr Shtaier
Modified: 2019-04-01 20:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:15:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 11959 None None None 2016-04-22 15:39:32 UTC

Description Oleksandr Shtaier 2015-06-29 11:25:14 UTC
Description of problem:
We can create new 'Content View Filter' object with description:
hammer -u admin -p changeme content-view filter create --name 'filter_test' --type rpm --content-view MEaNAFSQaK --organization-id 45 --description 'My Test'

But there are no way to get information about entity description through hammer:
hammer -u admin -p changeme content-view filter info --name 'filter_test' --content-view MEaNAFSQaK --organization-id 45
------------------------------------------------------------------------
Filter ID:    51
Name:         filter_test
Type:         rpm
Inclusion:    false
Repositories: 

Rules:
------------------------------------------------------------------------

Version-Release number of selected component (if applicable):
6.1 beta

How reproducible:
Always

Steps to Reproduce:
1. Create new content view
2. Add new content view filter with description to that content view
3. Read information about just created entity

Actual results:
There are no information about content view filter description in 'hammer content view info' output

Expected results:
Necessary information can be received through CLI

Additional info:

Comment 1 Oleksandr Shtaier 2015-06-29 11:26:33 UTC
Connected to:
Bug 1233612 - hammer info doesn't return all values for location
Bug 1082157 - hammer cli for sync-plan info does not return the sync plan description
...

Comment 2 RHEL Product and Program Management 2015-06-29 11:42:43 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Brad Buckingham 2015-09-24 20:16:19 UTC
Created redmine issue http://projects.theforeman.org/issues/11959 from this bug

Comment 5 Brad Buckingham 2015-09-24 20:19:06 UTC
hammer-cli-katello PR:
https://github.com/Katello/hammer-cli-katello/pull/321

example output:

hammer> content-view filter info --organization-id 1 --content-view-id 2 --id 1
Filter ID:    1
Name:         filter test
Type:         rpm
Inclusion:    false
Description:  this is a filter test
Repositories: 

Rules:

Comment 6 Bryan Kearney 2015-09-24 22:02:19 UTC
Upstream bug component is Content Management

Comment 7 Bryan Kearney 2015-09-24 22:02:21 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11959 has been closed
-------------
Brad Buckingham
Applied in changeset commit:hammer-cli-katello|314d5ee5fab9a0ad27147f5a4d33255dbbd86ae8.

Comment 8 Tazim Kolhar 2015-10-15 12:58:18 UTC
FAILEDQA:
# rpm -qa | grep foreman
nec-em17.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
foreman-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
nec-em17.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201510071112git33fd59b.el7.noarch
foreman-debug-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
foreman-release-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
foreman-postgresql-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
foreman-vmware-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-libvirt-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
foreman-ovirt-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
nec-em17.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
tfm-rubygem-foreman_discovery-4.1.0-1.fm1_10.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
foreman-proxy-1.11.0-0.develop.201510120849git5f36f2e.el7.noarch
foreman-compute-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
foreman-gce-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch



steps:
# hammer -u admin -p changeme content-view filter info --name 'test_filter' --content-view con_view --organization-id 1
Filter ID:    1
Name:         test_filter
Type:         rpm
Inclusion:    true
Repositories: 

Rules:

Comment 9 Tazim Kolhar 2015-10-15 13:05:37 UTC
*** This bug is failing in upstream ****.

Comment 10 Bryan Kearney 2015-10-15 14:02:57 UTC
Upstream bug component is Hammer

Comment 11 Bryan Kearney 2015-10-15 14:02:59 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11959 has been closed
-------------
Brad Buckingham
Applied in changeset commit:hammer-cli-katello|314d5ee5fab9a0ad27147f5a4d33255dbbd86ae8.

Comment 12 Tazim Kolhar 2015-10-27 12:26:59 UTC
*** This bug is failing in upstream ****.

# rpm -qa | grep foreman
foreman-proxy-1.11.0-0.develop.201510201341git00875b3.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
foreman-libvirt-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
foreman-compute-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-gce-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
foreman-debug-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
hp-sl2x170zg6-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
tfm-rubygem-foreman_discovery-4.1.1-1.fm1_11.el7.noarch
foreman-vmware-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
hp-sl2x170zg6-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-sl2x170zg6-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-ovirt-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
foreman-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
foreman-release-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
foreman-postgresql-1.11.0-0.develop.201510201422git6eb234a.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201510201150gitab068d9.el7.noarch

steps:
# hammer -u admin -p changeme content-view filter info --name 'test_filter' --content-view con_view1 --organization-id 1
Filter ID:    1
Name:         test_filter
Type:         rpm
Inclusion:    true
Repositories: 

Rules:
there is no description field .

Comment 13 Bryan Kearney 2015-10-27 14:02:27 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11959 has been closed
-------------
Brad Buckingham
Applied in changeset commit:hammer-cli-katello|314d5ee5fab9a0ad27147f5a4d33255dbbd86ae8.

Comment 15 Og Maciel 2016-03-24 17:27:38 UTC
[root@cloud-qe-10 ~]# hammer -u admin -p changeme content-view filter create --name 'filter_test' --type rpm --content-view MEaNAFSQaK --organization-id 3 --description 'My Test'
Warning: Option --id is deprecated. This option will be removed in Katello 2.5, Use --uuid
Filter created
[root@cloud-qe-10 ~]# hammer -u admin -p changeme content-view filter info --name 'filter_test' --content-view MEaNAFSQaK --organization-id 3
Warning: Option --id is deprecated. This option will be removed in Katello 2.5, Use --uuid
Filter ID:    1
Name:         filter_test
Type:         rpm
Inclusion:    false
Description:  My Test
Repositories:

Rules:

[root@cloud-qe-10 ~]# hammer -u admin -p changeme content-view filter create --name 'filter_test_two' --type rpm --content-view MEaNAFSQaK --organization-id 3
Warning: Option --id is deprecated. This option will be removed in Katello 2.5, Use --uuid
Filter created
[root@cloud-qe-10 ~]# hammer -u admin -p changeme content-view filter info --name 'filter_test_two' --content-view MEaNAFSQaK --organization-id 3
Warning: Option --id is deprecated. This option will be removed in Katello 2.5, Use --uuid
Filter ID:    2
Name:         filter_test_two
Type:         rpm
Inclusion:    false
Description:
Repositories:

Rules:

Comment 16 Og Maciel 2016-03-24 17:32:24 UTC
Verified as per previous comment on Satellite 6.2.0 SNAP 5.1

Comment 19 Bryan Kearney 2016-07-27 11:15:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.