Bug 123656 - NX bit interferes with Java JRE 1.4.2
NX bit interferes with Java JRE 1.4.2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 16:55 EDT by Mark Langsdorf
Modified: 2013-08-05 21:07 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-15 17:09:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Langsdorf 2004-05-19 16:55:30 EDT
Description of problem:
Sun Java JRE 1.4.2 crashes during execution if the noexecute option 
is enabled in RHEL3 U2 for AMD64.  The application does not crash if 
the 'noexec=off' command line parameter is passed to the kernel.

Version-Release number of selected component (if applicable):
Sun J2SE JRE 1.4.2
kernel 2.4.21-15EL

How reproducible:
Always.

Steps to Reproduce:
1.  Install RHEL3 U2 for AMD64 on an Opteron system.
2.  Install 32-bit Java JRE 1.4.2 on the same system.
3.  run `/usr/java/j2re1.4.2_04/bin/java -version` and observe 
unsightly crash message.
4.  Reboot system and pass `noexec=off` as a kernel boot paramater.
5.  Rerun `/usr/java/j2re1.4.2_04/bin/java -version` and observe 
"Java version 1.4.2_04"
  
Actual results:
huge ugly crash message

Expected results:
Java version "1.4.2_04"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_04-b05)
Java HotSpot(TM) Client VM (build 1.4.2_04-b05, mixed mode)

Additional info:
Comment 1 Hui Huang 2004-05-21 17:38:30 EDT
The support for NX bit has been added to Sun JDK 1.4.2_05
and 1.5-beta2. Both are in testing right now and will be
released to the public very soon. As Mark mentioned, boot
with 'noexec=off' will work around the problem.

If the change was made by mistake please fix it as soon as
possible; if it was made for security reasons, it should
be well documented in the release notes.
Comment 2 Bradley Thomas 2004-07-16 14:13:03 EDT
Is there an update you can provide on how testing has proceeded?  Has 
the version of the JDK with this fix now publicly available?
Comment 4 Jim Paradis 2004-08-23 19:34:04 EDT
This is indeed fixed as of 2.4.21-19.EL  Be aware, though, that there
is another outstanding Java issue: Bug 128735.

Comment 5 John Flanagan 2004-09-02 00:31:37 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-433.html
Comment 6 Pekka Savola 2004-12-15 06:43:28 EST
We've noted the same problem but the bug appears to be fixed only with
UP, so re-opening.

With SMP, it's still there (or at least one with similar symptoms) in
kernel-smp-2.4.21-20.0.1.EL.

Either using UP or passing noexec=off fixes the problem for that kernel.

The only related/similar PR I could find was #137138.

(note: 128735 above is non-public report.)
Comment 7 Ernie Petrides 2004-12-15 17:09:53 EST
Hello, Pekka.  The problem originally reported in this bug was fixed
in U3.  A variant of the problem, which I believe you've encountered,
has been fixed in U4 (related bugs are 137138, 137464, 142749).

I'm reclosing this bug.  Please feel free to test out the beta version
of U4 here:

  ftp://partners.redhat.com/a61d109e2483b0bf579b0b5f90a5ea8c/2.4.21-27.EL/

U4 is scheduled for release on Monday (12/20).  I've made bug 128735 public,
and I expect that one to be resolved with U4 as well.
Comment 8 Ingo Molnar 2005-01-04 07:54:58 EST
*** Bug 139930 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.