Bug 123659 - RFE: firewall option to trust specific IPs
RFE: firewall option to trust specific IPs
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-firewall (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 177950
  Show dependency treegraph
 
Reported: 2004-05-19 17:12 EDT by Jack Neely
Modified: 2013-11-06 14:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 14:37:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Neely 2004-05-19 17:12:37 EDT
Description of problem:
The firewall command in the kickstart config should have an option
that trusts specific IPs or hosts.  Possibly the --trust option can be
made to tell the difference between interfaces and IPs.

Think zephyr servers.
Comment 1 Jeremy Katz 2004-05-19 22:42:50 EDT
anaconda's interface for this stuff is going to be getting simpler,
not more complicated.  Having lokkit expose something like this that
could be used in a scripted fashion wouldn't be terrible, though (and
at that point, I might consider passing arbitrary options to the
firewall command on to lokkit)
Comment 2 Daniel L. Rall 2004-11-04 16:48:44 EST
Indeed!  Along the lines of bug 128046, this option should also be
available in the GUI.
Comment 3 Chris Lumens 2006-03-10 11:30:22 EST
Moving to Fedora since we're not going to be able to get a change like this into
RHEL3.
Comment 4 Thomas Woerner 2007-07-23 05:14:01 EDT
There will be a new firewall config tool for fedora soon. But the first version
will not have this feature, but it is on the todo list.
Comment 5 Thomas Woerner 2007-11-06 08:21:36 EST
Assigning to system-config-firewall.
Comment 6 Thomas Woerner 2013-11-06 14:37:27 EST
Closing because there will not be big changes to system-config-firewall anymore.

Note You need to log in before you can comment on or make changes to this bug.