Bug 123662 - Installer crashed while partitioning giving me an "exception error"
Installer crashed while partitioning giving me an "exception error"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 17:26 EDT by Truls Karlsen
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 18:21:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anacdump file it made on the floppy (35.68 KB, text/plain)
2004-05-19 17:27 EDT, Truls Karlsen
no flags Details
anaconda dump on my system (similar but different) (43.44 KB, text/plain)
2004-05-20 14:06 EDT, David Morse
no flags Details
Dump from Anaconda while trying to remove existing linux partitions (38.08 KB, text/plain)
2004-09-05 06:10 EDT, Graham Smith
no flags Details

  None (edit)
Description Truls Karlsen 2004-05-19 17:26:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
First I installed Fedora cleanly without any problems, but I forgot
that I had special partitioning-needs. So when I tried to install
again it asked me what I wanted to do. I said that it should erase all
old linux-partitions. Either there or the next step it crashed, asked
me to insert a floppy and told me to reboot the system. The dump-file
is at the url.

Version-Release number of selected component (if applicable):
Fedora Core2 dvdiso from the torrent-site.

How reproducible:
Didn't try


Additional info:
Comment 1 Truls Karlsen 2004-05-19 17:27:38 EDT
Created attachment 100357 [details]
Anacdump file it made on the floppy

it's also at http://login2.prefect.no/anacdump.txt
Comment 2 David Morse 2004-05-20 14:06:34 EDT
Created attachment 100382 [details]
anaconda dump on my system (similar but different)

I had almost the exact same anaconda crash w/ FC2 gold just now on a Latitude
CPx.  I have a dual-boot WinXP / FC1, and told the installer to erase all Linux
partitions so I could do a fresh FC2 install.

Here is my disk layout:

Disk /dev/hda: 12.0 GB, 12072517632 bytes
255 heads, 63 sectors/track, 1467 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot	    Start	  End	   Blocks   Id	System
/dev/hda1   *		1	  764	  6136798+   7	HPFS/NTFS
/dev/hda2	      765	  777	   104422+  83	Linux
/dev/hda3	      778	 1402	  5020312+  83	Linux
/dev/hda4	     1403	 1467	   522112+   f	W95 Ext'd (LBA)
/dev/hda5	     1403	 1467	   522081   82	Linux swap

I am attaching my anaconda dump.  It is very similar to the one above, except
mine died sanity checking swap instead of /:

  File "/usr/lib/anaconda/partitions.py", line 820, in sanityCheckAllRequests
    swapSize = swapSize + request.getActualSize(self, diskset)
  File "/usr/lib/anaconda/partRequests.py", line 450, in getActualSize
    raise RuntimeError, "Checking the size of a partition which hasn't been
allocated yet"
Comment 3 Ray Pitmon 2004-05-22 12:43:38 EDT
I had the same problem (not sure if it was the exact same error, but 
looks like it.)  I had just created 7 RAID1 partitions on each of two 
drives, assigned them md's, set their mount points, and had about 4 
gig left on one drive, so I tried to create a regular ext3 partition 
(mounted as /tmp2), and it crashed.
Comment 4 Graham Smith 2004-09-05 06:10:17 EDT
Created attachment 103474 [details]
Dump from Anaconda while trying to remove existing linux partitions
Comment 5 Jeremy Katz 2005-02-01 18:21:48 EST
Fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.