Bug 123670 - (MEGARAID) Compaq/HP Remote Insight Lightsout card is being detected at megaraid
Summary: (MEGARAID) Compaq/HP Remote Insight Lightsout card is being detected at megaraid
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-19 21:52 UTC by Rob Starkey
Modified: 2015-01-04 22:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-03 04:43:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vxx output as requested. (6.82 KB, text/plain)
2004-05-22 01:17 UTC, Rob Starkey
no flags Details

Description Rob Starkey 2004-05-19 21:52:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
System:
Compaq/HP DL360
Dual PIII 800mhz
4gigs of ram
Compaq hardware raid (cpqarray)

With the remote insight card installed, FC2's installer detects and
tries to load the megaraid driver making the system lockup/hang
requiring a power cycle.

The 'workaaround' is to boot with noprobe and select the modules by
hand but this is bad because it breaks kickstart and upgrades.

Version-Release number of selected component (if applicable):
FC2

How reproducible:
Always

Steps to Reproduce:
1. Boot FC2 install CD
    

Additional info:

Comment 1 Alan Cox 2004-05-21 23:29:26 UTC
Can you attach an lspci -vxx

Comment 2 Rob Starkey 2004-05-22 01:17:56 UTC
Created attachment 100442 [details]
lspci -vxx output as requested.

Here ya go.

Comment 3 Alan Cox 2004-05-22 15:40:05 UTC
Something like this should fix it

--- drivers/scsi/megaraid.c~    2004-05-22 16:34:01.976198176 +0100
+++ drivers/scsi/megaraid.c     2004-05-22 16:36:02.088938264 +0100
@@ -4609,6 +4609,20 @@
  
        pci_bus = pdev->bus->number;
        pci_dev_func = pdev->devfn;
+
+       if(pdev->vendor == PCI_VENDOR_ID_INTEL)         /* The
megaraid3 stuff reports the id of the intel
+                                                          part which
is not remotely specific to the megaraid */
+       {
+               /* Don't fall over the Compaq management cards using
the same PCI identifier */
+               if(pdev->subsystem_vendor == PCI_VENDOR_ID_COMPAQ &&
+                  pdev->subsystem_id == 0xC000)
+                       return -ENODEV;
+               /* Now check the magic signature byte */
+               pci_read_config_word(pdev, PCI_CONF_AMISIG, &magic);
+               if(magic != HBA_SIGNATURE_471 && magic != HBA_SIGNATURE)
+                       return -ENODEV;
+               /* Ok it is probably a megaraid */
+       }
  
        /*
         * For these vendor and device ids, signature offsets are not


Comment 4 Alan Cox 2004-05-22 15:52:44 UTC
Posted a final version of that to linux-kernel and the maintainer


Comment 5 Mike Cotton 2004-09-16 23:09:30 UTC
Alan,

I am expereincing this same issue, do I need to create a new iso with 
the updated kernel?  

Thanks.

Mike

Comment 6 Alan Cox 2004-09-16 23:31:21 UTC
If you can remove the compaq card you should be able to install,
upgrade to the kernel errata and then reinstall the card. That is
probably the easiest approach.


Comment 7 Dave Jones 2004-11-03 04:43:39 UTC
fixed in FC3, (and soon FC2 update).
Alan, this seems to still not be upstream as of 2.6.9 (havent checked 2.6.10rc)


Note You need to log in before you can comment on or make changes to this bug.