Bug 1236722 - Rpmconf not displaying help screen
Summary: Rpmconf not displaying help screen
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmconf
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1215868 (view as bug list)
Depends On: 1237075
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-29 19:53 UTC by Lukas Zapletal
Modified: 2015-11-22 13:52 UTC (History)
3 users (show)

Fixed In Version: rpmconf-1.0.12-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-18 01:59:18 UTC
Type: Bug


Attachments (Terms of Use)

Description Lukas Zapletal 2015-06-29 19:53:21 UTC
After my upgrade from 21 to 22, rpmconf is no longer displaying information about key bindings. I just saw "==> Package distributor has shipped an updated version.Your choice:"

That would be not big problem, but Ctrl+C did not work properly and I decided to keep pressing enter thinking that the default beavior is to do nothing. That ended up with all my configuration files randomly overwritten. I was trying "?" or "h" to display help screen, but that did not hit the mark. I managed to display it somehow, not sure what key it was. I need to investigate what happened, but my report here is:

- help screen is not displaying properly
- ctrl+c should work
- default behaviour should be nothing rather than (something not sure what it was)

For the record, here is my whole session:

[lzap@lzapx ~]$ sudo rpmconf -a
Configuration file '/etc/sysconfig/libvirt-guests'
-rw-r--r-- 1 root root 1860 Apr  3  2014 /etc/sysconfig/libvirt-guests
-rw-r--r-- 1 root root 2185 Jun  6 17:24 /etc/sysconfig/libvirt-guests.rpmnew

 ==> Package distributor has shipped an updated version.Your choice: 
Configuration file '/etc/libvirt/libvirtd.conf'
Your choice: ^C^C^C^C^C^C^C
^C^C^CConfiguration file '/etc/lvm/lvm.conf'
Your choice: ^C^C^C^C
Configuration file '/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.45-40.b14.fc22.x86_64/jre/lib/security/US_export_policy.jar'
Your choice: 
Configuration file '/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.45-40.b14.fc22.x86_64/jre/lib/security/java.security'
-rw-r--r-- 1 root root 20481 Mar 19 09:53 /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.45-40.b14.fc22.x86_64/jre/lib/security/java.security
-rw-r--r-- 1 root root 20495 Jun 10 19:34 /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.45-40.b14.fc22.x86_64/jre/lib/security/java.security.rpmnew

Your choice: ^C^C^C^C^C
Configuration file '/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.45-40.b14.fc22.x86_64/jre/lib/security/local_policy.jar'
-rw-r--r-- 1 root root 638 Dec 15  2014 /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.45-40.b14.fc22.x86_64/jre/lib/security/local_policy.jar
-rw-r--r-- 1 root root 556 Jun 10 20:05 /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.45-40.b14.fc22.x86_64/jre/lib/security/local_policy.jar.rpmnew

 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:Your choice: ?
Configuration file '/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.45-40.b14.fc22.x86_64/jre/lib/security/local_policy.jar'
-rw-r--r-- 1 root root 638 Dec 15  2014 /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.45-40.b14.fc22.x86_64/jre/lib/security/local_policy.jar
-rw-r--r-- 1 root root 556 Jun 10 20:05 /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.45-40.b14.fc22.x86_64/jre/lib/security/local_policy.jar.rpmnew

 ==> Package distributor has shipped an updated version.
Your choice: ^C^C^C
Configuration file '/etc/pulse/default.pa'
-rw-r--r-- 1 root root 5550 Mar 19 17:55 /etc/pulse/default.pa.rpmnew
-rw-r--r-- 1 root root 5788 Mar 25 09:36 /etc/pulse/default.pa

 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
Your choice:  
Configuration file '/etc/lightdm/lightdm.conf'
-rw-r--r--. 1 root root 4714 Aug 30  2013 /etc/lightdm/lightdm.conf
-rw-r--r--  1 root root 6391 Oct  9  2014 /etc/lightdm/lightdm.conf.rpmnew

 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      M     : merge configuration files
      Z     : background this process to examine the situation
      S     : skip this file
 The default action is to keep your current version.
Your choice: d
Configuration file '/etc/lightdm/lightdm.conf'
-rw-r--r--. 1 root root 4714 Aug 30  2013 /etc/lightdm/lightdm.conf
-rw-r--r--  1 root root 6391 Oct  9  2014 /etc/lightdm/lightdm.conf.rpmnew

 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      M     : merge configuration files
      Z     : background this process to examine the situation
      S     : skip this file
 The default action is to keep your current version.
*** aliases (Y/I/N/O/D/M/Z/S) [default=N] ? 
Your choice: q
Configuration file '/etc/lightdm/lightdm.conf'
Your choice: q
Configuration file '/etc/lightdm/lightdm.conf'
Your choice: ?
Configuration file '/etc/lightdm/lightdm.conf'
Your choice: h
Configuration file '/etc/lightdm/lightdm.conf'
-rw-r--r--. 1 root root 4714 Aug 30  2013 /etc/lightdm/lightdm.conf
-rw-r--r--  1 root root 6391 Oct  9  2014 /etc/lightdm/lightdm.conf.rpmnew

 ==> Package distributor has shipped an updated version.Your choice: 
Configuration file '/etc/mock/default.cfg'
lrwxrwxrwx 1 root root 20 Oct  8  2014 /etc/mock/default.cfg -> fedora-20-x86_64.cfg
lrwxrwxrwx 1 root root 20 Jun 29 21:09 /etc/mock/default.cfg.rpmnew -> fedora-22-x86_64.cfg

 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      M     : merge configuration files
      Z     : background this process to examine the situation
Your choice: 
Configuration file '/etc/mock/fedora-20-x86_64.cfg'
-rw-r--r-- 1 root mock 1830 Jan  8 21:51 /etc/mock/fedora-20-x86_64.cfg
-rw-r--r-- 1 root mock 1818 Apr 29 15:07 /etc/mock/fedora-20-x86_64.cfg.rpmnew

 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      M     : merge configuration files
      Z     : background this process to examine the situation
      S     : skip this file
 The default action is to keep your current version.
*** aliases (Y/I/N/O/D/M/Z/S) [default=N] ? Your choice: 
Configuration file '/etc/systemd/journald.conf'
-rw-r--r-- 1 root root 811 Apr  1 09:50 /etc/systemd/journald.conf
-rw-r--r-- 1 root root 969 Jun  9 15:16 /etc/systemd/journald.conf.rpmnew

 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
Your choice: ^C^C^C^C^C^C^C^C^C

Comment 1 Miroslav Suchý 2015-06-30 11:42:13 UTC
> - help screen is not displaying properly
Fixed in commit 66b896e.

> - ctrl+c should work
I find this as bug 1237075. I put workaround in rpmconf code.

> - default behaviour should be nothing rather than (something not sure what it was)
The default behaviour is to delete .rpmnew and .rpmsave, i.e. keep what you have currently installed. It is the same behaviour as in Debian. And I do not think it should be changed.

Comment 2 Fedora Update System 2015-06-30 12:45:08 UTC
rpmconf-1.0.12-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/rpmconf-1.0.12-1.fc22

Comment 3 Lukas Zapletal 2015-06-30 14:15:28 UTC
Thanks Mirek

> > - default behaviour should be nothing rather than (something not sure what it was)
> The default behaviour is to delete .rpmnew and .rpmsave, i.e. keep what you
> have currently installed. It is the same behaviour as in Debian. And I do
> not think it should be changed.

If the default option is shown on the help screen which I was missing, than that's fine. If not, indicating what happened would be nice (a message).

Comment 4 Lukas Zapletal 2015-06-30 14:17:02 UTC
The default action is to keep your current version

It is there, that is fine. Thanks for help!

Comment 5 Fedora Update System 2015-07-02 17:07:04 UTC
Package rpmconf-1.0.12-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpmconf-1.0.12-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-11006/rpmconf-1.0.12-1.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-07-18 01:59:18 UTC
rpmconf-1.0.12-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Miroslav Suchý 2015-11-22 13:52:30 UTC
*** Bug 1215868 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.