Bug 123677 - Nautilus won't unmount media
Nautilus won't unmount media
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fam (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 18:48 EDT by Kyrre Ness Sjøbæk
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 04:47:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyrre Ness Sjøbæk 2004-05-19 18:48:48 EDT
Description of problem:
When i have mounted removable media trough nautilus, and accessed 
data on them using external applications (opened documents in OO, 
mozilla etc.), and try to unmount, I get the error message "Device is 
Buisy". An "lsof | grep <name of removable media, such as cdrom>" 
shows that fam is holding it open.

I hope this is the correct place to report this bug, if not, may you 
please point me to the correct site?

Version-Release number of selected component (if applicable):


How reproducible:
Se description

Steps to Reproduce:
1.
2.
3.
  
Actual results:
error message. Having to kill fam or logout/in

Expected results:
device gets unmounted

Additional info:

This bug seemed to be resolved in the last days of test 3, but its 
back in core 2
Comment 1 Zack Cerza 2004-06-30 15:29:46 EDT
FAM is the issue here, it has nothing to do with Nautilus. Reassigning.
I've actually experienced this bug in KDE on Debian unstable recently.

For more info:
http://oss.sgi.com/archives/fam/2004-02/msg00000.html
http://bugzilla.gnome.org/show_bug.cgi?id=102760
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=234787
Comment 2 Kyrre Ness Sjøbæk 2004-06-30 16:56:52 EDT
This bug is actually resolved. It was resolved within days of the
release of FC2, i think it was the libgnome/libkde which fixed it. Not
shure. Anyway, the problem seems to be gone now, so i will suggest
that its status is changed to WORKSFORME
Comment 3 Daniel Veillard 2004-08-30 04:47:03 EDT
This should be fixed now.

Daniel

Note You need to log in before you can comment on or make changes to this bug.