Bug 123679 - Search field in New Bug initial screen doesn't allow Searching
Search field in New Bug initial screen doesn't allow Searching
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 19:22 EDT by Darryl Dixon
Modified: 2013-06-23 23:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 16:54:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darryl Dixon 2004-05-19 19:22:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When you want to enter a New bug in Bugzilla the first page presented
encourages you to Search for existing similar bugs (obviously to
prevent duplicates from being logged).  However, instead of actually
taking the search terms supplied and searching Bugzilla for instances
of those terms, it instead barfs and complains that none of them are
'Valid Keywords', and advises you to click 'Back' and try again.  If
one does this and simply clicks 'Search' again without changing
anything, half the time it will barf again, and the other half it will
actually Search.  This is an intermittent fault that I cannot see any
pattern, rhyme, or reason in.


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Click the 'New' tab at the top of Bugzilla 
2.Go to the Search field and enter 'java netscape crash' (this is the
example search supplied in the help instructions immediately above)
3.Leave everything as default and click Search
                                                                     
                                                       


Actual Results:  Bugzilla complains that 'java netscape crash' is not
a valid keyword and links to the list of valid keywords (Triaged, etc)


Expected Results:  Bugzilla should search the Summary (and/or
Description) fields properly for the words specified in the Search
text box.


Additional info:

As mentioned, this is intermittent.  Usually the very first time I run
it, it will fail, but if I then return to it and try again, it will
work, and from then on for the rest of that session it will work.
Comment 1 Bill Nottingham 2004-05-24 17:35:01 EDT
*** Bug 123680 has been marked as a duplicate of this bug. ***
Comment 2 David Lawrence 2006-04-08 14:08:56 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.
Comment 3 David Lawrence 2008-09-16 12:50:58 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.

Note You need to log in before you can comment on or make changes to this bug.