Bug 123692 - Exception Occured problem
Exception Occured problem
Status: CLOSED DUPLICATE of bug 119447
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 22:27 EDT by Dan
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan 2004-05-19 22:27:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
hi its me again running into the same problem I had with anaconda in
FC2 test 3.
Exception occured during the post install
thought it was fixed but I guess not
anyways I would like to see the x86_64 version of Fedora running on my
AMD64
Note that this was with the GUI install I will try the text install
next :)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.go through install process in graphical mode
2.install packages
3.watch Exception Occured Message pop up
    

Actual Results:  install stops
unable to boot operating system

Expected Results:  install completed
boot into Fedora Core 2

Additional info:

text of message:
"Exception Occured

An unhandled exception has occured.  This is most likely a bug.
Please copy full text of this exception and file a detailed bug report
against anaconda at http://bugzilla.redhat.com/bugzilla/

Traceback (most recent call last):
File "/usr/lib/anaconda/gui.py", line 1048, in handleRenderCallback
self.currentWindow.renderCallback()
File "/usr/lib/anaconda/iw/progress_gui.py", line 242, in
renderCallback self.intf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py", line 763, in nextClicked
self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep
rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 1125, in doPostInstall
devnull = os.open("/dev/null", os.O_RDWR)
OSError: [Errno 5] Input/output error:'/dev/null'
Comment 1 Dan 2004-05-20 00:12:28 EDT
ok sorry to say almost same results for the text install:
"File "/usr/bin/anaconda", line 1131, in ? intf.run(id, dispatch,
configFileData)
File "/usr/lib/anaconda/text.py", line 475, in run dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 169, gotoNext self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep rc =
apply(func, self.bindArgs(args))
File "usr/lib/anaconda/packages.py", line 1125, in doPostInstall
devnull = os.open("/dev/null", os.O_RDWR)
OSError: [Errno 5] Input/output error:
'/dev/null'"
Comment 2 Kevin van Gool 2004-06-29 18:33:30 EDT
I am having the exact same problems with the Fedora Core 2 
installation.
Comment 3 Pete Stieber 2004-07-09 12:58:00 EDT
See bug number 124029. The work around for me was to use

linux mem=256M

when installing. My HW

MB: Tyan Tomcat K8S(S2850G2N)
Processor: AMD Opteron 146 (2GHz)
RAM: 1 GB
HD: Maxtor 80GB 7200 RPM IDE ULTRA ATA 133

Maybe it's a problem with x86_64 systems with more that X MB of 
memory where X > 256M.
Comment 4 Jeremy Katz 2004-10-07 14:18:44 EDT

*** This bug has been marked as a duplicate of 119447 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:03:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.