Bug 1236945 - glusterfsd crashed while rebalance and self-heal were in progress
Summary: glusterfsd crashed while rebalance and self-heal were in progress
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1214169 1235735 1238535
Blocks: qe_tracker_everglades 1223915
TreeView+ depends on / blocked
 
Reported: 2015-06-30 04:30 UTC by Raghavendra G
Modified: 2016-06-16 13:17 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1214169
Environment:
Last Closed: 2016-06-16 13:17:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-30 10:30:29 UTC
REVIEW: http://review.gluster.org/11462 (protocol/server: start listening only after all xlators in graph are initialised.) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 2 Anand Avati 2015-07-01 05:04:54 UTC
REVIEW: http://review.gluster.org/11462 (protocol/server: start listening only after all xlators in graph are initialised.) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 3 Anand Avati 2015-07-01 11:27:11 UTC
REVIEW: http://review.gluster.org/11490 (protocol/server: fail setvolume if any of xlators is not initialized yet) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 4 Anand Avati 2015-07-02 11:11:59 UTC
COMMIT: http://review.gluster.org/11490 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 4242857196697d3fcfc0c7a75ede4a666518ea0b
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Wed Jul 1 16:54:55 2015 +0530

    protocol/server: fail setvolume if any of xlators is not initialized yet
    
    We can only start recieving fops only when all xlators in graph are
    initialized.
    
    Change-Id: Id79100bab5878bb2518ed133c1118554fbb35229
    BUG: 1236945
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/11490
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 5 Raghavendra G 2015-07-06 05:36:53 UTC
There is a crash uncovered by [1]. Hence moving this bug back to assigned.

http://blog.gmane.org/gmane.comp.file-systems.gluster.devel

[1] http://review.gluster.org/11490

Comment 6 Raghavendra G 2015-07-06 05:47:00 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1240161 has been filed to track crash mentioned in comment 5. Hence moving back this bug to MODIFIED.

Comment 7 Anand Avati 2015-07-06 13:39:57 UTC
REVIEW: http://review.gluster.org/11553 (protocol/server: fix detection of graph readiness for serving I/O) posted (#2) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)

Comment 8 Niels de Vos 2016-06-16 13:17:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.