Bug 123728 (TB0f8c06ef) - TokenRingInterface.py:74:init_gui:RuntimeError: could not create GladeXML object
Summary: TokenRingInterface.py:74:init_gui:RuntimeError: could not create GladeXML object
Status: CLOSED RAWHIDE
Alias: TB0f8c06ef
Product: Fedora
Classification: Fedora
Component: system-config-network   
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-20 11:48 UTC by Eddahbi Karim
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-02 04:43:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace generated by system-config-network (868 bytes, text/plain)
2004-05-20 11:53 UTC, Eddahbi Karim
no flags Details

Description Eddahbi Karim 2004-05-20 11:48:26 UTC
Description of problem:
I haven't any Token Ring card.
I tried to launch the Token Ring configuration wizard given with
internet-druid but the wizard didn't start and internet-druid crashed.
It seems to be related to the GUI, Glade and to system-config-network

Version-Release number of selected component (if applicable):
system-config-network 1.3.16


How reproducible:
Always on my box.

Steps to Reproduce:
1. Launch internet-druid
2. Select "Token Ring connection"
3. Press Forward
  
Actual results:
system-config-network crash with a backtrace

Expected results:
Launch the Token Ring configuration wizard.
Druids can call wizards, can't they ? :)

Additional info:
Internet-druid is related to system-config-network, this is why I
selected system-config-network in the component list.
Plus, it seems that internet-druid is not a valid component for bugzilla

Comment 1 Eddahbi Karim 2004-05-20 11:53:21 UTC
Created attachment 100375 [details]
Backtrace generated by system-config-network

If I select "Debug" and I type :
(Pdb) bt full

I got that :

  /usr/sbin/internet-druid(277)?()
-> main()
  /usr/sbin/internet-druid(156)main()
-> gtk.mainloop()
 
/usr/src/build/377922-noarch/install/usr/share/system-config-network/netconfpkg/gui/NewInterfaceDialog.py(123)on_start_page_next()

 
/usr/src/build/377922-noarch/install/usr/share/system-config-network/netconfpkg/gui/TokenRingInterface.py(122)get_druids()

>
/usr/src/build/377922-noarch/install/usr/share/system-config-network/netconfpkg/gui/TokenRingInterface.py(74)init_gui()


Plus, when the application crashes, I got that on the terminal :

(system-config-network:6974): XML-CRITICAL **: Start tag expected, '<' not
found 
 
(system-config-network:6974): libglade-WARNING **: did not finish in
PARSER_FINISH

Parsing problems ?
I'll try to 'strace' this.

Comment 2 Eddahbi Karim 2004-05-20 12:02:16 UTC
The .py called by internet-druid is located there :

/usr/share/system-config-network/netconfpkg/gui/TokenRingInterface.py

but internet-druid try to search everywhere but not there...

Strange...

Comment 3 Eddahbi Karim 2004-05-21 22:58:15 UTC
The kernel 2.6.6-1.374 didn't solve the problem so I don't think it's
related to the kernel at all.

Comment 4 Alan Cox 2004-05-21 23:18:47 UTC
Duplicated here


Comment 5 Harald Hoyer 2004-06-04 12:49:28 UTC
seems like the glade file is corrupted

Comment 6 Eddahbi Karim 2004-07-02 04:43:29 UTC
Fixed in system-config-network 1.3.17.

Thanks


Note You need to log in before you can comment on or make changes to this bug.