Bug 123745 - FC2 x86_64 POST INSTALL Failure on a Shuttle SN85G4. dev directory corrupt
FC2 x86_64 POST INSTALL Failure on a Shuttle SN85G4. dev directory corrupt
Status: CLOSED DUPLICATE of bug 119447
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 09:07 EDT by Dr J Austin
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacona dump file shows problem with ram0 line 4154 onwards (138.73 KB, text/plain)
2004-05-21 05:54 EDT, Dr J Austin
no flags Details
/dev and /etc listings and mount table after failure (9.53 KB, text/plain)
2004-05-21 06:07 EDT, Dr J Austin
no flags Details

  None (edit)
Description Dr J Austin 2004-05-20 09:07:27 EDT
Description of problem:
Installation fails during Post Install of FC2-x86_64
File /usr/lib/anaconda/gui.py line 1048 in handleRenderCallback
File /usr/lib/anacona/iw/progress_gui.py line 242
File /usr/lib/anaconda/gui.py line 763
File /usr/lib/anaconda/dispatch.py line 169
File /usr/lib/anaconda/dispatch.py line 237
File /usr/lib/anaconda/packages.py line 1125

devnull= os.open("/dev/null",os.O_RDWR)
OSError:[Errno1]Operation not permitted:'/dev/null'

Version-Release number of selected component (if applicable):
Fedora Core 2 x86_64
The same problem was present in FC2T2 but Not in FCT3 !!
Upon inspection of the dev directory from Cont/Alt/F2
/mnt/sysimage/dev is corrupt as shown with an ls -l
The layout is correct but ? marks and large numbers present
in the listing - No correct /dev/null entry !!!!

Upon mounting the incomplete install disk the /dev directory is OK



How reproducible:
Very for a full install, I have managed one successful install with
the smallest install option. Tried approx 10 times with
FC2T2 and FC2


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
The machine is a Shuttle SN85G4
The same happens on a PATA /dev/hda1 install and with
SATA /dev/sda1 install
The DVD version was used for installation

Just about possible to get the failed install to boot but obviously
most of the post install stuff hasn't happened.
No passwd, network, X configuration etc
Comment 1 Ed Bailey 2004-05-20 11:54:38 EDT
Changing component to something a bit more appropriate...
Comment 2 Dr J Austin 2004-05-21 05:54:33 EDT
Created attachment 100412 [details]
anacona dump file shows problem with ram0 line 4154 onwards

anaconda dump file shows ram0 problem
Comment 3 Dr J Austin 2004-05-21 06:07:27 EDT
Created attachment 100413 [details]
/dev and /etc listings and mount table after failure
Comment 4 Dr J Austin 2004-05-21 11:42:54 EDT
The original bug comment should say
/dev directory is corrupt. NOT /mnt/sysimage/dev !!!!
Comment 5 Alan Cox 2004-05-21 19:15:53 EDT
Does this box pass memtest86 >?
Comment 6 Dr J Austin 2004-05-22 07:47:09 EDT
I have run memtest86+ v1.15 for over 2hrs on default test sequence
Zero errors !
More machine info
Athlon64 3200+ proc, 1GB memory, sata_sil raid driver being used with 
a single disk - no RAID.
PATA disk /dev/hda Maxtor 6Y080L0
hda1 40GB FC2-i386 now installed here and it runs cleanly
      FC2-x86-64 fails post install here as well
hda2 2G swap
hda3 37G FC2T3 Installed here, runs OK
SATA disk /dev/sda Maxtor 6Y080M0
sda1 78G FC2 fails post install here, will boot, but lots of fiddling
sda2 2G swap
TWO swap partions are available 
Disk /dev/hda: 81.9 GB, 81964302336 bytes
16 heads, 63 sectors/track, 158816 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes
   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1       81270    40960048+  83  Linux
/dev/hda2           81271       85333     2047752   82  Linux swap
/dev/hda3           85334      158816    37035432   83  Linux
Disk /dev/sda: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        9700    77915218+  83  Linux
/dev/sda2            9701        9964     2120580   82  Linux swap
Comment 7 Rory Gleeson 2004-06-14 08:31:04 EDT
I've had similar problems trying to install FC2 x86_64  on my box. 
Basically, I don't get an error but the CPU will just stop sucking
data from the disc and it will just sit there.  So, this may be a
separate bug.

However, I've been having issues tweaking my motherboard, where I find
most of my problems lie (and which I'm slowly elimating).

I have a K8V SE Deluxe.  Ahtlon64 3000 CPU.  Note the *SE*.  ASUS made
a number of changes to the K8V Deluxe on their Second Edition model. 
I'm noticing that a number of distros haven't taken this in to
consideration.  

Anyway, it's a shot in the dark, but I thought I'd check, in case, at
its root, we're dealing with the same problem.

Rory Gleeson
Toronto, Canada
Comment 8 Dr J Austin 2004-06-15 07:23:10 EDT
15-6-2004
Reran memory tests for 11 hours following help from fedora-list (KAS)
Still no errors
However ...
I have now managed to install FC2
I tried many more times,different install combinations, finally
re-partitioning the hard disk (KAS) having
sda1    /boot   100MB
sda2    /       75GB
sda3    swap    3GB
instead of
sda1    /       76GB
sda2    swap    2GB

Did a full install ie ticking every box but NOT the Everything box
about 4.2GB not 6.7GB

No boot loader installed on sda

The POST INSTALL did not fall over but I am sure this is because
for some reason it no longer has to open /dev/null.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
The /dev directory is still corrupt !!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

I feel sure there is still a problem with accessing over the end of
/dev/ram0 during install, it is just that some (most) install
sequences don't need to use the address space that has been corrupted.
J Austin
Comment 9 Pete Stieber 2004-07-09 13:32:05 EDT
See bug number 124029. The work around for me was to use

linux mem=256M

when installing. My HW

MB: Tyan Tomcat K8S(S2850G2N)
Processor: AMD Opteron 146 (2GHz)
RAM: 1 GB
HD: Maxtor 80GB 7200 RPM IDE ULTRA ATA 133

Maybe it's a problem with x86_64 systems with more that X MB of 
memory where X > 256M.
Comment 10 David Heinzinger 2004-07-14 17:22:33 EDT
I have a tyan k8w with dual opterons 512 meg of memory, radeon 9200.

The adding of mem=256M made it so I could complete the install.

Now I reboot and all the screen says is 

GRUB

No cusor, nothing.

Dave
Comment 11 Alan Cox 2004-07-14 17:41:10 EDT
K8W dual opteron is a known to work tested configuration. The screen
saying GRUB and nothing else suggests a very different problem with
GRUB being unable to find the rest of its loaded. Thats a known
problem if you tried to install on the SI controller and raid is
enabled for it in the bios (because BIOS raid and Linux don't agree
and there is a distinct lack of docs on the bios raid layout)
Comment 12 Jeremy Katz 2004-10-07 14:20:19 EDT

*** This bug has been marked as a duplicate of 119447 ***
Comment 13 Red Hat Bugzilla 2006-02-21 14:03:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.