Bug 1238063 - libgfchangelog: Example programs are not working.
Summary: libgfchangelog: Example programs are not working.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-01 06:34 UTC by Kotresh HR
Modified: 2016-06-16 13:18 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 13:18:34 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2015-07-01 06:34:34 UTC
Description of problem:
The example programs provided with the source to test libgfchangelog library is broken.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
1. Edit the brick path in the program corresponding to the brick paths in test volume
2. Compile with pkgconfig options as follows for the C example files
   gcc -o gethistory `pkg-config --cflags libgfchangelog` get-history.c `pkg-config --libs libgfchangelog`
3. Run the program

Actual results:
changelog_register fails

Expected results:
Changelog_register should not fail

Additional info:

Comment 1 Anand Avati 2015-07-02 13:16:37 UTC
COMMIT: http://review.gluster.org/11479 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 2f5355f76a8168bc504cba8237f0825fc181fce8
Author: Kotresh HR <khiremat@redhat.com>
Date:   Wed Jul 1 12:06:42 2015 +0530

    libgfchangelog: Fix example programs
    
    Incorporate the new API 'gf_changelog_init'
    introduced in libgfchangelog which should
    be called before 'gf_changelog_register'.
    
    Change-Id: I10a9dd5ff3ecc64fd61dcb6b1aa53739e0bdeedd
    BUG: 1238063
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/11479
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 2 Niels de Vos 2016-06-16 13:18:34 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.