Bug 1238141 - [virtio-win][pvpanic]win10-32 guest can not detect pvpanic device in device manager
Summary: [virtio-win][pvpanic]win10-32 guest can not detect pvpanic device in device m...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Gal Hammer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-01 09:35 UTC by lijin
Modified: 2015-12-04 16:48 UTC (History)
8 users (show)

Fixed In Version: qemu-kvm-rhev-2.3.0-15.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:48:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description lijin 2015-07-01 09:35:48 UTC
Description of problem:


Version-Release number of selected component (if applicable):
win10-32 build 9926/10074/10130

How reproducible:
100%

Steps to Reproduce:
1.boot win10-32 guest with pvpanic device "-device pvpanic,id=pvpanic0,ioport=0x0505"

2.install pvpanic driver in device manager 

Actual results:
can not detect pvpanic device in device manager,there is no "Unknown device" or any pvpanic key word device 

Expected results:
can detect pvpanic device correctly and can install pvpanic driver successfully.

Additional info:

Comment 2 Gal Hammer 2015-07-02 12:04:02 UTC
I can see the "Unknown device" when using qemu-kvm-2.1.3-8.fc21.x86_64 and Windows10_InsiderPreview_x32_EN-US_10130.iso.

Which version of qemu are you working with? What is the full command line?

Thanks.

Comment 3 lijin 2015-07-03 02:12:19 UTC
(In reply to Gal Hammer from comment #2)
> I can see the "Unknown device" when using qemu-kvm-2.1.3-8.fc21.x86_64 and
> Windows10_InsiderPreview_x32_EN-US_10130.iso.
> 
> Which version of qemu are you working with? What is the full command line?
> 
> Thanks.

qemu version:qemu-kvm-rhev-2.3.0-6.el7.x86_64

full cli:
/usr/libexec/qemu-kvm -name 105PNCW10D32G9F -enable-kvm -m 3G -smp 4 -uuid c4b09e9d-e915-4016-8cf3-3717c31f90ba -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/105PNCW10D32G9F,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=105PNCW10D32G9F,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=Windows10_InsiderPreview_x32_EN-US_10130.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=105PNCW10D32G9F.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:15:5c:9a:84,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:3 -vga cirrus -cpu Nehalem,+fsgsbase -device pvpanic,id=pvpanic0,ioport=0x0505 -monitor stdio

Comment 4 Gal Hammer 2015-07-03 08:25:14 UTC
(In reply to lijin from comment #3)
> (In reply to Gal Hammer from comment #2)
> > I can see the "Unknown device" when using qemu-kvm-2.1.3-8.fc21.x86_64 and
> > Windows10_InsiderPreview_x32_EN-US_10130.iso.
> > 
> > Which version of qemu are you working with? What is the full command line?
> > 
> > Thanks.
> 
> qemu version:qemu-kvm-rhev-2.3.0-6.el7.x86_64
> 
> full cli:
> /usr/libexec/qemu-kvm -name 105PNCW10D32G9F -enable-kvm -m 3G -smp 4 -uuid
> c4b09e9d-e915-4016-8cf3-3717c31f90ba -nodefconfig -nodefaults -chardev
> socket,id=charmonitor,path=/tmp/105PNCW10D32G9F,server,nowait -mon
> chardev=charmonitor,id=monitor,mode=control -rtc
> base=localtime,driftfix=slew -boot order=cd,menu=on -device
> piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive
> file=105PNCW10D32G9F,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,
> cache=none -device
> ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive
> file=Windows10_InsiderPreview_x32_EN-US_10130.iso,if=none,media=cdrom,
> id=drive-ide0-1-0,readonly=on,format=raw -device
> ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive
> file=105PNCW10D32G9F.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none
> -global isa-fdc.driveA=drive-fdc0-0-0 -netdev
> tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device
> rtl8139,netdev=hostnet0,id=net0,mac=00:52:15:5c:9a:84,bus=pci.0,addr=0x3
> -chardev pty,id=charserial0 -device
> isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0
> -vnc 0.0.0.0:3 -vga cirrus -cpu Nehalem,+fsgsbase -device
> pvpanic,id=pvpanic0,ioport=0x0505 -monitor stdio

Thanks for the additional information. I'll try to reproduce.

BTW: Does the problem still occurs if you use just "-device pvpanic,id=pvpanic0" or when giving ioport a value of 0x505 (without the leading zero)?

Comment 5 lijin 2015-07-08 03:19:14 UTC
still hit the issue with "-device pvpanic,id=pvpanic0" or when giving ioport a value of 0x505.
And win10-64 and win2016 also hit the same issue

Comment 6 Gal Hammer 2015-07-23 16:30:44 UTC
I've used git bisect and the problem is with commit 2332333c9738b442fbbd5b83a1eaa6be656ab9b5.

Comment 7 Gal Hammer 2015-07-23 16:39:16 UTC
More info: commit 2332333c added a _STA method to the device's ACPI description. The method returns a value which tells Windows not to show the device in the UI. 

This needs to be fixed in qemu.

Comment 8 Gal Hammer 2015-07-26 08:01:42 UTC
A patch was posted upstream.

Comment 9 Miroslav Rezanina 2015-07-29 14:20:19 UTC
Hi Gal,
you provided patch for qemu-kvm-rhev. Do we need to fix this in qemu-kvm too?

Comment 11 Gal Hammer 2015-07-29 14:37:50 UTC
(In reply to Miroslav Rezanina from comment #9)
> Hi Gal,
> you provided patch for qemu-kvm-rhev. Do we need to fix this in qemu-kvm too?

I think the patch should be included in qemu-kvm as well.

Comment 12 Miroslav Rezanina 2015-08-05 08:19:48 UTC
Fix included in qemu-kvm-rhev-2.3.0-15.el7

Comment 13 lijin 2015-08-10 03:07:26 UTC
re-try with qemu-kvm-rhev-2.3.0-15.el7,win10-32/64 can detect the pvpanic device correctly.
So this issue has been fixed already,thanks a lot.

Comment 15 Qian Guo 2015-08-13 06:12:05 UTC
According to comment 13, this bug is fixed, so set status as verified.

Comment 17 errata-xmlrpc 2015-12-04 16:48:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.