Bug 123832 - Partition alignment problems on multiple dual boot systems
Partition alignment problems on multiple dual boot systems
Status: CLOSED DUPLICATE of bug 115980
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-05-20 17:15 EDT by Paul Crabb
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:03:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Paul Crabb 2004-05-20 17:15:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Epiphany/1.2.4

Description of problem:
In the past 2 days I've performed 4 installs of Fedora Core 2 that
have complained about partition alignments.

The first was a system with a 60 gig hard drive partitioned 23gig for
windows, 1gig for swap, and the rest for Fedora.  When the install
completed no matter where I installed the Grub loader the windows
partiton and MBR was corrupt.  Had to use the Samsung low level
diagnostics utility to zero the mbr and start over.  Tried
partitioning with fdisk, cfdisk, partition magic, and the windows
installer without success.  Finally scrapped the FC2 install on this

2 of the installs were on Toshiba laptops with 30 gig hard drives. 16
gig for windows, 1gig for swap, and the rest for linux.  Install did
not corrupt the windows partiton but the Linux partition is
unbootable. Only used the FC2 disk druid to partition these.

Last system is a Dell Optiplex GX150.  When trying to install on this
machine I received the Partition alignment error and aborted the install.

All of these machines had Fedora Core 1 installed on the without issue .

I am trying to do a full, new install not an upgrade.

Version-Release number of selected component (if applicable):
Fedora Core 2 Installer

How reproducible:

Steps to Reproduce:
1.Boot with install CD
2.Select defaults for language, and keyboard options.
3.Warning screen appears

Actual Results:  WARNING: Unable to align partition properly.  This
probably means that another partitioning tool generated an incorrect
partition table, because it didn't have the correct BIOS geometry. It
is safe to ignore, but ignoring may cause (fixable) problems with some
boot loaders.

Expected Results:  No warning message.

Additional info:
Comment 1 Jeremy Katz 2004-05-20 18:37:37 EDT

*** This bug has been marked as a duplicate of 115980 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.