Bug 1238329 - Cannot disable SSLv3 and use TLS only
Summary: Cannot disable SSLv3 and use TLS only
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tog-pegasus
Version: 6.6
Hardware: Unspecified
OS: Unspecified
Target Milestone: rc
: ---
Assignee: Vitezslav Crhonek
QA Contact: qe-baseos-daemons
Petr Bokoc
Depends On:
Blocks: 1172231 1253743 1272873 1310222
TreeView+ depends on / blocked
Reported: 2015-07-01 15:37 UTC by Yoshifumi Kinoshita
Modified: 2019-07-11 09:31 UTC (History)
6 users (show)

Fixed In Version: tog-pegasus-2.12.0-4.el6
Doc Type: Bug Fix
Doc Text:
Pegasus CIM server now disables SSLv3 and uses TLS1.0 or later by default The Pegasus CIM server previously had no option to disable the SSLv3 protocol, which is now considered insecure. This update contains a backported upstream fix which changes the default behavior so that SSLv3 is disabled, TLS1.0 or later is used, and SSLv3 can be reenabled using the `sslBackwardCompatibility` option if necessary.
Clone Of:
Last Closed: 2016-05-10 19:37:19 UTC

Attachments (Terms of Use)

System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0745 normal SHIPPED_LIVE tog-pegasus bug fix update 2016-05-10 22:31:15 UTC

Comment 5 Alois Mahdal 2015-10-29 15:24:49 UTC
Concerns we have raised in RHEL7 regarding scope of this change (and sslBackwardCompatibility option) apply here as well:

(In reply to Alois Mahdal from bug 1264951 comment #0)
> > sslBackwardCompatibility
> >
> >        Description:This  setting  specifies  whether  the ssl supports
> >        SSLv3 and versions of TLS lesser than 1.2 .Ideally for security
> >        Compilance purposes it is by default set to false.
> >        Default Value: false
> >        Dynamic: No
> Per consultation with security QA (Hubert Kario):
> While SSLv3 is indeed insecure and dangerous, the same cannot be said
> about TLS1.1 or even TLS1.1, so the option effect is a bit excessive.
> Since it's off by default, in fact it introduces regression: any clients
> that do not use TLS1.2 but will try TLS1.0 or TLS1.1 will be refused.

Patch from aforementioned bug changes the scope to "by default, accept tls1.0+ but not older".  Would it be possible to include it?

If so, should we do it in this bug or clone the other one to RHEL6.8 (ack would be granted in that case, although I do like the first option more)?

Comment 8 Alois Mahdal 2016-01-18 18:39:00 UTC
Vito, could you please set 'Fixed In Version:' field?

For now I'm assuming it's tog-pegasus-2.12.0-4.el6 (the one currently attached to erratum) but better to be sure.

Comment 9 Vitezslav Crhonek 2016-01-21 08:20:13 UTC
(In reply to Alois Mahdal from comment #8)
> Vito, could you please set 'Fixed In Version:' field?
> For now I'm assuming it's tog-pegasus-2.12.0-4.el6 (the one currently
> attached to erratum) but better to be sure.

Sorry, done.

Comment 10 Alois Mahdal 2016-03-04 10:22:07 UTC
Re-used the same test as in RHEL7; the new setting works fine.

No regressions found.

Comment 12 errata-xmlrpc 2016-05-10 19:37:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.